JCE 2.1.3 has been released. This update fixes the INVALID PATH error on attempting to edit non-local files or images. In addition the detection of invalid file paths and names has been improved.

    Updating to JCE 2.1.3 

    Updating to JCE 2.1.3 from a previous JCE 2.0 version can be done using the JCE Updates dialog (available from the JCE Control Panel) or using the Update Manager in Joomla! 2.5. Alternatively update by installing the new version over the old using the Joomla! Installer.

    Click here for a complete changelog

    Download