Joomla! Compatibility

JCE 2.9.x is available for Joomla! 3.9 and later. Compatability with earlier versions of Joomla 3.x is possible but not guaranteed.

JCE 2.8.x is available for Joomla! 3.6.x - 3.8.x - This version is no longer developed, maintained or supported.

JCE 2.6.x is available for Joomla! 1.5.26, Joomla! 2.5.28 - This version is no longer developed, maintained or supported.

Browsers

JCE is built for Firefox, Chrome, BraveMicrosoft Edge, Safari and Opera. The latest versions of all browsers is recommended. IE11 will be officially supported at the minimum level required for operation until Microsoft Edge browsers are available for Windows 7 and 8.

Server-side / hosting requirements

JCE has the same server-side requirements as Joomla! and functions best with safe-mode off.

JCE 2.9.x requires PHP 5.6 or later. As PHP 5.6 is no longer officially supported, PHP 7.2 or later is recommended - https://www.php.net/supported-versions.php

If your server is using the PHP Suhosin extension, the suhosin.post.max_vars option must be set to 1000 or greater.

JCE Pro requires the PHP GD2 or PHP IMagick extensions for image processing. PHP IMagick is recommended as it is able to process larger images using less memory than GD2.

Other requirements

An understanding of the Joomla! administrative functions is required, especially the installation and general use of Plugins and Components.

To use the popup features of the Image Manager Extended, Link and Media Manager, JCE MediaBox is recommended.