You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)
  Friday, 24 September 2021
  1 Replies
  826 Visits
Hello
2-3 weeks ago, I ceased being able to save edits in JCE and in TinyMCE. I thought it might be resolved with new software as it came but that has not happened.
Today, my Siteground hosting Help found the below.
Can anyone make suggestions on my next steps from this information.
Thank you
Scott


Hello Scott,

Thank you for contacting our Help Desk!

I have carefully checked the case and during my tests, no errors were recorded in our Mod Security log file or any other error log file on our server.

However, I have noticed that the following error occurs in the browser console log right after I hit the "Save & Close" button:

index.php?option=com_content&view=article&layout=edit&id=461:164 Uncaught TypeError: Cannot read properties of null (reading 'isValid')
at Object.Joomla.submitbutton (index.php?option=com_content&view=article&layout=edit&id=461:164)
at HTMLButtonElement.onclick (index.php?option=com_content&view=article&layout=edit&id=461:830)


You can verify that with the following screenshot:

https://prnt.sc/1te9uz8

That issue is most probably caused by a conflict between some modules but currently, I am not able to detect which one might be problematic.

For your convenience, I have found an article where a similar problem was discussed and several solutions were provided:

https://forum.joomla.org/viewtopic.php?t=875171&start=30

According to the results, the problem is caused by your Joomla application itself. Those kinds of problems are outside the scope of our support and require the specialized intervention of a Joomla developer.
more than a month ago
·
#108923
I ceased being able to save edits in JCE and in TinyMCE.


So the issue is not specific to JCE but occurs with Tinymce as well, which suggests the problem is caused by another extension you have installed.

The first thing to do is ensure that you are using the latest version of everything, including Joomla 3.x, as this issue may have already been fixed in the extension causing it.

If that fails, the next thing to check is with the "No Editor" option (yuo can select this as the editor in the Joomla Global Configuration). This will rule out anything specific to do with the processes of both editors (JCE and Tinymce) and confirm the problem with a 3rd party extension.

If this is the case, the next part is a little more difficult, as you will need to find and disable that extension, and unless you have a suspect in mind, this will have to happen one at a time. The most likely culprits are Joomla Plugins - start with editor-xtd and system plugins.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!