You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Tuesday, 05 October 2021
  16 Replies
  653 Visits
I am trying to upload an mp4 video file in Easy Discuss. I'm getting an "Unable to upload file" message. I'm using Amazon S3 for storage. Please advise.
2 weeks ago
·
#108991
Are you able to upload the file in the JCE File Browser in the JCE Admin?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#108992
Yes. I was able to upload in JCE Admin and Amazon S3. I deleted the file and tried uploading it to the front end again. I'm still getting the message but the file is showing in JCE Admin and Amazon.
2 weeks ago
·
#108994

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#109044
I have fixed this on your site with an install of JCE Pro 2.9.17 beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#109049
I uploaded and saw the Amazon link but nothing happens when I insert the video. The window is blank.
one week ago
·
#109066
Please install Amazon S3 Filesystem 2.2.6 - https://www.joomlacontenteditor.net/downloads/plugins/amazon-s3-filesystem

and JCE Pro 2.9.17 Beta 6 - https://www.joomlacontenteditor.net/downloads/editor/pro/development

As Amazon S3 items are uploaded as "Private" by default, you might want to set the deafult ACL option in the Amazon S3 Filesystem parameters to "Public Read", as there is no option to set the ACL level when uploading in the Basic Dialog.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#109067
My ACL was set to Public. I'll try it, thanks.
one week ago
·
#109068
Sorry, when I insert the video nothing appears.
one week ago
·
#109070
The Media Manager requires the Media Support option to be enabled in Editor Profiles -> Features & Layout, which I have done on your site.

I have also then disabled all media types that it supports (IFrames, Audio, Object, Embed) except for HTML5 Video.

Uploading and inserting a video is now working as expected.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#109073
Hello Ryan. It works, thanks! Is there a way to resize the player and remove the download button in the controls?
one week ago
·
#109077
Is there a way to resize the player and remove the download button in the controls?


The media player is provided by the browser, and there isn't currently a cross-browser method for editing or removing individual parts of the player.

Chromium based browsers (Chrome, Brave, Edge etc.) can use a controlsList attribute on the video tag to remove features from the player, eg:


<video src="/video.mp4" controlsList="nodownload nofullscreen">


and it is possible to resize the player with css (added to your template stylesheet), eg:


video::-webkit-media-controls-enclosure {
width: 50% !important;
}


but none of this works in other browser, such as Firefox.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#109082
JW Player would be a good media player under Media Options. Maybe this can be added in the future for HTML videos. Thanks for your help.
one week ago
·
#109085
JW Player would be a good media player under Media Options.


JW Player is not free - https://www.jwplayer.com/pricing

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#109086
Yes, I know. It requires a license. I'm saying it would be great to offer the ability to enter JW license info in Media Options.
one week ago
·
#109090
I have found an alternative media player - https://plyr.io/ - which I am making into a Joomla plugin.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#109092
NIce!
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!