You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  Friday, 08 October 2021
  4 Replies
  819 Visits
Hi,
I'm using JCE Editor (pro) with joomla 4.0.3.
I often use the mediajce field to upload documents, video and audio files, in custom extensions.
On joomla 4 the mediatype attribute is ignored, I can upload/select images only.

I also tried JCE Pro version 2.9.17 Beta 5 but the problem persists.


<field
name="data_sheet"
type="mediajce"
preview="false"
label="Data sheet"
mediatype="files"
/>


Thank you.
more than a month ago
·
#109151
Accepted Answer

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#109091
This is working correctly in my tests, using the xml you posted above.

Have you made any changes to the Permitted File Extensions for the File Browser in Editor Profiles -> Plugin Parameters -> File Browser?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#109093
You're right, I think we've found the problem.
By disabling the "Direct Upload" option, the url attribute of the media field is not correctly overwritten and it point to
index.php?option=com_jce&task=mediafield.display&fieldid={field_id}&mediatype=images
more than a month ago
·
#109151
Accepted Answer

Just because you're not paranoid doesn't mean everybody isn't out to get you.

nineloops selected the reply #109151 as the answer for this post — 1 month ago
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!