You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Wednesday, 13 October 2021
  5 Replies
  484 Visits
Hi, I've been a JCE user for a long time. Have always used rollovers and love how easy it is to create them. Today, for some reason, they aren't working. I found a support page where it said you have to turn them on in the editor parameters/Advanced. But the options for events is no longer there. I am perplexed. I have never had to turn anything on before and my other rollovers on the site are still working.
one week ago
·
#109089
Today, for some reason, they aren't working. I found a support page where it said you have to turn them on in the editor parameters/Advanced. But the options for events is no longer there.


As rollovers use a javascript enabled HTML attribute, this presents a security risk to site owners from untrusted contributors. These "event attributes" are therefore disabled by default, and can be enabed by setting Allow Event Attributes to Yes in Editor Profiles -> Editor Parameters -> Advanced.

Please see - https://www.joomlacontenteditor.net/support/faq/editor/rollover-tab-missing

I have never had to turn anything on before and my other rollovers on the site are still working.


Existing rollovers will continue to function as these have already been created.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#109094
That's the problem. I am not seeing anything in the editor parameters/advanced like this. It doesn't look like this. Am I missing something? I didn't manage this site for a while. I am wondering if the client got the free version while I wasn't looking?
one week ago
·
#109095
The Allow Event Attributes option is automatically enabled it the Allow Javascript option is enabled, which it appears to be on your site.

Are you seeing the Rollover tab in the Image Manager, and are you able to create a rollover image in the editor?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#109096
:) That's the problem. The rollover tab is there. I can create them. But when I go to the front end, they aren't working. There is no mouse over. I am perplexed. I have been doing mouse overs since they were possible. I used to hand code them. (JCE is so much easier, BTW). It is only happening on this site. I am imagining there is some kind of conflict somewhere. Maybe?
one week ago
·
#109099
The rollover tab is there. I can create them. But when I go to the front end, they aren't working. There is no mouse over.


This is probably because the onmouseover and onmouseout attributes have been removed by the Joomla Text Filter when you saved the content.

See the Configure Joomla Article Filters section here - https://www.joomlacontenteditor.net/support/faq/editor/scripts-removed-on-saving

Just because you're not paranoid doesn't mean everybody isn't out to get you.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!