You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Friday, 15 October 2021
  5 Replies
  790 Visits
Hey Ryan

I've gone through several threads on this forum trying to get this to work and despite having what appears to be a valid configuration, Iframes still do not work whether pasted in via code or added via the media button.


  • Text filters in global config are set to no filtering for super users
    The default profile is the only enabled one and is in position #1
    Media support is enabled under Features & Layout
    iframe is not in extended elements or prohibited elements
    Allow iframes is set to "Yes" in Plugin Parameters > Media Support


I can get the iframe in if I paste it in code view and click save. But toggling between code view and editor removes the iframe. Using the media button to try and add an iframe, it simply isn't added when you click insert.

Please let me know what else I should be doing.
more than a month ago
·
#109215
Accepted Answer
You had JCE Pro 2.9.8 installed, I have installed the latest version - JCE Pro 2.9.16 on your site.

The requirement for iframes to have a src attribute was removed in JCE Pro 2.9.11

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#109123
Does this happen with all IFrame content, or just a specific url?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#109125
All iframe content. I have tried the URL I'm trying to add and also things like Google.co.uk

Are there any plugins installed by jce that potentially need to be ordered? I know some rsjoomla software requires certain plugin order positions.
more than a month ago
·
#109126

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#109215
Accepted Answer
You had JCE Pro 2.9.8 installed, I have installed the latest version - JCE Pro 2.9.16 on your site.

The requirement for iframes to have a src attribute was removed in JCE Pro 2.9.11

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#109216
Didn't even consider that as an option.... Apologies and many thanks
qlue selected the reply #109215 as the answer for this post — 1 month ago
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!