You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Friday, 12 November 2021
  9 Replies
  585 Visits
Hi Ryan,

I am a long time user and paid subscriber of JCE Editor and load JCE Editor on every website I build. I rarely have any issue (this is my first post here).

My current problem is on one client website where text pasted into content has no container element. Typing the text and pressing the enter key works fine.

This is a recent issue that I have not been able to solve despite comparing settings between the affected website and other websites that do not have the issue.

In particular, I have checked the following settings:

  • Components -> JCE Editor Pro -> Global Configuration -> Clipboard -> Container Element & Enter Key is set to Paragraph : Paragraph
  • Components -> JCE Editor Pro -> Profiles -> Default -> Features & Layout -> Markdown is not enabled
  • Components -> JCE Editor Pro -> Profiles -> Default -> Editor Parameters -> Advanced -> Protect Shortcode is not enabled
  • Components -> JCE Editor Pro -> Profiles -> Default -> Plugin Parameters -> Clipboard settings look reasonable to me

This is causing a particular issue at the moment as Regular Labs ReReplacer expects to see either <p> or <div> container elements to be able to make some replacements which are no longer working for the client.

The affected website is using JCE Editor Pro 2.9.17.

If you have any suggestions, I would love to hear them.

Thanks,

Neil
2 weeks ago
·
#109474
Accepted Answer
I found a bug in previous versions of the JCE Pro 2.9.18 beta which may be a cause of the issue. Please try JCE Pro 2.9.18 Beta 9 - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Just because you're not paranoid doesn't mean everybody isn't out to get you.

3 weeks ago
·
#109388

Just because you're not paranoid doesn't mean everybody isn't out to get you.

3 weeks ago
·
#109420
Thanks Ryan,

I have installed JCE Pro 2.9.18 Beta 6 but this has not solved the issue.

Neil
2 weeks ago
·
#109434
Can you post an example of the code you are pasting in, so I can test it?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#109458
Thanks Ryan,

An example of the pasted text is {video-640} although the issue happens whatever the text is e.g. xyz.
2 weeks ago
·
#109462
An example of the pasted text is {video-640} although the issue happens whatever the text is e.g. xyz.


This appears to be working OK on the demo site - https://demo.joomlacontenteditor.net

Can you confirm this?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#109472
The demo site works fine for me.

Pasting via the "Paste" or "Paste as Plain Text" buttons seems to work around the problem so I have advised my client to do that in the meantime.

Thanks Ryan.
2 weeks ago
·
#109474
Accepted Answer
I found a bug in previous versions of the JCE Pro 2.9.18 beta which may be a cause of the issue. Please try JCE Pro 2.9.18 Beta 9 - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#109480
Hi Ryan,

That's fixed it, thanks so much for all your hard work!

Neil
webilicious selected the reply #109474 as the answer for this post — 2 weeks ago
2 weeks ago
·
#109481
Great! JCE Pro 2.9.18 will be released next week.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!