You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Wednesday, 15 December 2021
  8 Replies
  2K Visits
Hi Ryan,

In the latest version of the editor the assignment of classes is not possible, In previous versions you could select a class and it was added by clicking next to the dropdown. But this doesn't work anymore. Only when a class is manually added to the code, I'm able to add more classes.

In the zip there is an animated gif to show the problem.

Thanks in advance.
more than a month ago
·
#109799
Unless I've misunderstood you, this is working fine in my tests on the demo site - https://demo.joomlacontenteditor.net

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#109802
I found the problem! The styles work in the articles but not in a repeatable field in a module in which the editor is added. Then you get the behavior explained in the initial post.
Rixters selected the reply #109802 as the answer for this post — 6 months ago
Rixters revoked the reply #109802 as the answer for this post — 6 months ago
more than a month ago
·
#109803
FYI: In 2.9.18-beta2 the style in the repeatable module fields still worked.
more than a month ago
·
#109804
I can't reproduce this in a standard editor repeatable field.

but not in a repeatable field in a module in which the editor is added


I this a Custom HTML module or something specific to an installed extension?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#109815
I found the problem! It is not specific to the editor field in a module.

How to reproduce the issue:
1. Go to "Editor Profiles" and select "Default profile"
2. Open the Plugin Parameters tab and go to the "Style Select" option
3. in "Styles List Options" disable "Editor / Profile Stylesheets" and enable "Custom Styles"
4. Add some classes to the "Custom Classes" field and save the settings
5. Got to an article and try to apply the classes. The classes will not be added to the selected text. Behavior is visible in the animated gif in the first post.

Hope you are able to reproduce the issue.

For now I switched of the custom classes and the styles work again.
more than a month ago
·
#109819

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#110003
I'm having the same problem, even after installing the JCE Pro 2.9.19 Beta 2 version.
more than a month ago
·
#110013
QBParis - This is working in my tests with the latest beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Just because you're not paranoid doesn't mean everybody isn't out to get you.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!