You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)
  Tuesday, 08 March 2022
  5 Replies
  1K Visits
Hello,

i am using JCE Editor on Joomla 4.1. I have defined a style sheet in the JCE configuration to override the default styles, but the Hx titles and the links do not display the chosen colors. All other styles are well applied. Do you know why ?

Thanks,
Regards
GBteam changed the title from Styles CSS dans editeur Joomla 4 to Styles CSS into editor with Joomla 4 — 3 months ago
more than a month ago
·
#110536

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#110538
Hello,

I'm not against sending you the credentials, but I'm having the same problem on all sites that use joomla 4.1. I don't think I'm alone in this case.
The issue appear since the 4.0.6 to 4.1 update, because the template.css path has changed to media folder.

The editor no longer find the styles of the template.css file by default, you have to give it the new path to it into the JCE global configuration. This manipulation works, except for titles and links that do not display the right color. Am I understandable?

Thanks,
Regards.
more than a month ago
·
#110539

The issue appear since the 4.0.6 to 4.1 update, because the template.css path has changed to media folder.
The editor no longer find the styles of the template.css file by default, you have to give it the new path to it into the JCE global configuration.


I'm fixing this for the next update.

you have to give it the new path to it into the JCE global configuration. This manipulation works, except for titles and links that do not display the right color.


If you are using a custom css file, you should add an @import rule for the template's css file, eg:


/* import template.css if your custom css file is in the same folder */
@import url('template.css');

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#110541
Thanks for your quick answer. I will try this or wait for next update, and come back to you.

Regards
more than a month ago
·
#110542
You can test out the fix in JCE Pro 2.9.21 Beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Just because you're not paranoid doesn't mean everybody isn't out to get you.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!