You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)
  Monday, 16 May 2022
  6 Replies
  294 Visits
Discovered some bugs regarding Image Manager Extended and captions.

#1: Add an image in Image Manager Extended, set Alignment = Centre. Image is now displayed centered in the editor. Highlight the image, Click Insert Caption, and click Update, image is then moved to the left. Save article, and the image is now centered again.

Also sometimes the "re-centering" after save fails, though not sure how to recreate.

#2: Add an image in Image Manager Extended. Highlight the caption instead of the image. Click Insert Caption, and click Update, the image is now stretched along the whole editor screen.

This works ok in JCE 2.9.20, but fails in 2.9.21+, including the latest 2.9.23 RC5.
NJK changed the title from Bugs in Image Manager Extended to Bugs using captions in Image Manager Extended — 1 month ago
more than a month ago
·
#111060

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111068
Thanks, that fixes bug #1.

My description of bug #2 wasn't good enough, here's an updated version:
Add an image in Image Manager Extended. Highlight the image, Click Insert Caption, either dont' set alignement or set it to anything else but Right, and click Update. Next highlight the caption instead of the image. Click Insert Caption, and click Update, and the image is now stretched along the whole editor screen.

One more thing I see (this is also in 2.9.20) is that once a caption has been added, changing the alignement of the image has no effect. Is this also a bug?
more than a month ago
·
#111071
My description of bug #2 wasn't good enough, here's an updated version:


My mistake. I didn't take notice of the second part! :(

Please try JCE Pro 2.9.23 RC 8 - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111073
Thanks, bug #2 fixed.

And then the final question. I notice that once a caption has been added to an image, the Aligment field in IME is shown as empty, and changing the value has no effect. (This is true also for version 2.9.20). So I'm wondering if this is by design, or a bug?
more than a month ago
·
#111074
So I'm wondering if this is by design, or a bug?


It's sort of by design, but admittedly a bit awkward. The alignment is no longer on the image itself, but has been transferred to caption container. To adjust the alignment, you will need to do it via the Caption dialog.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111080
Yes, I see it now, in the Container tab.

Thanks,
Frode
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!