You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)
  Wednesday, 18 May 2022
  8 Replies
  327 Visits
Being a newbie on JCE PRO, (and not very proficient on CSS) I may miss some basic things, so excuse my ignorance.
When I open JCE for editing an article or category, I see the editor icons in B/W and not in colour like I saw on a screen shot in the "editor toolbar" documentation. I must be missing something.
Also the default font size is 12px, which I seem unable to change.
I am using Helix Ultimate 2.0.8 as template for my site.
Screenshot attached. Schermafbeelding 2022-05-18 om 11.02.45.png
more than a month ago
·
#111078
Accepted Answer
When I open JCE for editing an article or category, I see the editor icons in B/W and not in colour like I saw on a screen shot in the "editor toolbar" documentation. I must be missing something.


The documentation needs updating as it is still showing the Classic icon set. The B/W icons are high-resolution icons for retina displays, so best suited for modern screens. You can switch to the Classic icon set in Editor Profiles -> Features & Layout.

Also the default font size is 12px, which I seem unable to change.
I am using Helix Ultimate 2.0.8 as template for my site.


The font size is set by your template, usually in the body tag. Ideally any changes to the font size should be done to the template stylesheet (you can probably do this using the Helix configuration tools) rather than changing font size and styles in the editor.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111078
Accepted Answer
When I open JCE for editing an article or category, I see the editor icons in B/W and not in colour like I saw on a screen shot in the "editor toolbar" documentation. I must be missing something.


The documentation needs updating as it is still showing the Classic icon set. The B/W icons are high-resolution icons for retina displays, so best suited for modern screens. You can switch to the Classic icon set in Editor Profiles -> Features & Layout.

Also the default font size is 12px, which I seem unable to change.
I am using Helix Ultimate 2.0.8 as template for my site.


The font size is set by your template, usually in the body tag. Ideally any changes to the font size should be done to the template stylesheet (you can probably do this using the Helix configuration tools) rather than changing font size and styles in the editor.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111079
Thanks a million for this quick and complete response!

You made me a fan of JCE PRO!

Rik
Ryan selected the reply #111078 as the answer for this post — 1 month ago
more than a month ago
·
#111084
I did search further for the fint size in the editor window. When fiddling the typography in Helix Ultimate all works wel in all pages, EXCEpt the editor window. Somehow the font here is always Helvetica, 12px, whatever I try.

I suspect it must be buried deep in a CSS file?

regards,
more than a month ago
·
#111089
Helix Ultimate oesn't appear to write custom changes to a file, but rather renders them as inline styles on the page, which is why they are not picked up by JCE.

You will need to create an editor.css file for JCE to use, in the templates/shaper_helixultimate/css/ folder, and add the following:


@import url('bootstrap.min.css');
@import url('template.css');

/* if you are using a preset, add the preset number here, eg: */
@import url('presets/preset1.css');

/* add your typography changes here, eg: */
body{
font-family: 'Arial', sans-serif;
font-size: 14px;
}


JCE will then detect and load this editor.css file instead of the others.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111098
I added the editor template file as suggested, but no result, always opens with Helvetica 12px. Tried in Safari, Microsoft Edge, Firefox. Version of template CSS file added, and screenshot of where it sits.

It remains a mystery to me. this is not major, but annoying to educate additional article editors.

You tickled my curiosity!

Rik Schermafbeelding 2022-05-20 om 15.26.55.png
more than a month ago
·
#111099
This is working in my tests with your editor.css file.

Please send me a login - https://www.joomlacontenteditor.net/contact/site-login

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111100
The Editor Styles option in the Editor Global Configuration was set to Default but it should be Template CSS File. I have set this option on your site and the stylesheets appear to be loading as expected.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111101
I must be missing something. When I create a new category, or a new article, the editor opens with a too small font size. I attach a screenshot with the opening text, en below it, the desired font size. The Schermafbeelding 2022-05-21 om 09.18.58.png

Regards
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!