You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Wednesday, 22 June 2022
  9 Replies
  163 Visits
After todays update the JCE Pro doesn't works anymore correct. It's not possible to save items!
one week ago
·
#111303
I'm not seeing this issue. Are you trying to save an article in the Joomla Article Manager? Please provide details of your issue.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#111306

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#111307
After Update to 2.9.26 it's still the same situation:
it's not possible to edit content with JCE - see images

Regards
Heinz
one week ago
·
#111308
Dear Ryan, we can confirm. JCE 2.9.26 is not saving anything unless im logged in as a super user. I've switched back to 2.9.24 which is totally working.
In our case, we have created a new user group and granted ALL access rights. The user attributed to this group wants to edit an extra field (type = Editor). As mentioned, this was always working and it no longer works since the last automatic update to 2.9.26.
one week ago
·
#111309
JCE 2.9.26 is not saving anything unless im logged in as a super user. I've switched back to 2.9.24 which is totally working.
In our case, we have created a new user group and granted ALL access rights. The user attributed to this group wants to edit an extra field (type = Editor). As mentioned, this was always working and it no longer works since the last automatic update to 2.9.26.


Does this user use a different editor profile to the Super User?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#111310
I can reproduce this issue in Joomla 3.10.10 with JCE 2.9.26:

  • in AcyMailing after saving a newsletter, the page refreshes and the content is not saved.
  • after saving an article, the page refreshes and the article shows the previous content.

I tested it on 2 different websites and with Google Chrome and FireFox.

However when I switch to TinyMCE, I can save the article/newsletter.

Kind Regards,
Peter Martin (aka pe7er)
http://www.db8.nl - Joomla! implementation, programming, template and component development

one week ago
·
#111311
This appers to occur when the editor does not have any tabs, ie: you have not enabled the Code tab and/or Preview tab for the editor.

Can you confirm this?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#111312
Thank you for your fast answer!
TL;DR it seems related to using a Custom JCE Editor Profile

Because of your question, I noticed that the "HTML Source" button which was available in JCE 3.9.24, is missing in 3.9.26.
I did not reconfigure anything, I just updated JCE 3.9.24 > 3.9.26.

I checked somewhat more. When I use JCE's "Default" profile, the editor has a Editor/Code/Preview on the right. And then I am able to save the article text. The not-saving issue occurs when I use my own JCE Profile.

So it seems that from 3.9.24 to 3.9.26 some setting has been changed that you have to re-configure in your own Editor Profile.

Kind Regards,
Peter Martin (aka pe7er)
http://www.db8.nl - Joomla! implementation, programming, template and component development

one week ago
·
#111313
Please try JCE Pro 2.9.27 Beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development

So it seems that from 3.9.24 to 3.9.26 some setting has been changed that you have to re-configure in your own Editor Profile.


The Toggle Editor button is now disabled by default, see - https://www.joomlacontenteditor.net/news/jce-pro-2-9-25-released

Just because you're not paranoid doesn't mean everybody isn't out to get you.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!