You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Friday, 22 July 2022
  4 Replies
  146 Visits
Hi Ryan, I am using the template manager to load a html template. I want to add an additional feature. I drop down so users can select from a list of items to display.

I have the html working fine outside of JCE and Joomla but whn I load it into JCE all the links to the jquery cdn and the script tags are stripped.

Is there a way in the template manager that I don't see to have the script load with the template ?

Thanks for your help
Steve

(I tried posting the code but it was blocked on my previous attempt to post)
2 weeks ago
·
#111517
I have the html working fine outside of JCE and Joomla but whn I load it into JCE all the links to the jquery cdn and the script tags are stripped.

Does it work if you paste the HTML into the Code tab?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#111524
Hi Ryan
If it cut and paste the html into the code tab *the script is shown in the window) if I switch tabs they are removed or on save they are removed also.
I have also tried setting up no text filter and whitelisted script for that user group without much luck. (this is Joomla 3.10) I even tried removing the script and link from the filterinput.php file.

Steve
I attached the template so you can see my code.
one week ago
·
#111525
Scripts must be enabled in the Editor Profiles. Please see - https://www.joomlacontenteditor.net/support/faq/editor/scripts-removed-on-saving

Just because you're not paranoid doesn't mean everybody isn't out to get you.

one week ago
·
#111534
Thanks Ryan, that definitely helped

Steve
Ryan marked this post as Resolved — 1 week ago
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!