You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Thursday, 10 November 2022
  4 Replies
  140 Visits
For some time now, saving an article with a table no longer works.
In the table I place an image and I link an pdf or mp3 file to it.
If I do that in the backend it works fine.
But if I do that in the frontend, the link breaks.
This is what can be seen in the relevant cell when I view the article online:


a href="/images/oefenen/oefenbestanden/2023_-_Joseph_Jongen_en_Arvo_Pärt/Pärt_-_Da_pacem_Domine/Part_-_Da_pacem_Domine_-_tekst.pdf" ">" " " " ">">">"

You can see it in theexample in the attachment.

What could be wrong? And how could I solve that?
3 weeks ago
·
#112290
Accepted Answer
I think this is caused by the Joomla Text Filter. I have seen a number of reports recently where HTML that contains UTF-8 characters is being mangled by the Joomla Text Filter when saving content.

Your Super User probably has the Filter Type option in System -> Global Configuration -> Text Filters set to No Filtering, so the content is not being filtered on saving, whereas the font-end usergroup Filter Type option is set to Default Forbidden List, so the content is filtered. This appears to be a bug in Joomla 4.2

Just because you're not paranoid doesn't mean everybody isn't out to get you.

3 weeks ago
·
#112279
If I do that in the backend it works fine.
But if I do that in the frontend, the link breaks.


Is this the same user in the front-end as the back-end?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

3 weeks ago
·
#112289
No it's not the same user.
In the backend I have been logged in as Super Admin and in the frontend as frontend editor.

The strange thing is that I didn't change the permissions for that frontend user group and it worked fine for a long time

Today I logged into the frontend with the SU account.
And with that I can adjust the table well.

I just wouldn't know why the frontend user can't do that.

The frontend permissions are now set to Editor not Publisher.
Could that still have nothing to do with it?
I'm going to test with it early next week.
3 weeks ago
·
#112290
Accepted Answer
I think this is caused by the Joomla Text Filter. I have seen a number of reports recently where HTML that contains UTF-8 characters is being mangled by the Joomla Text Filter when saving content.

Your Super User probably has the Filter Type option in System -> Global Configuration -> Text Filters set to No Filtering, so the content is not being filtered on saving, whereas the font-end usergroup Filter Type option is set to Default Forbidden List, so the content is filtered. This appears to be a bug in Joomla 4.2

Just because you're not paranoid doesn't mean everybody isn't out to get you.

3 weeks ago
·
#112292
Hi Ryan,
Thank you for your support.
Indeed, Text filter was set to Default for that group.
I believe it has worked in the past.
But maybe that was just Joomla 3.

I have now also set the Text filter to None for this user group.
And with that the problem is solved.
woodyf4u selected the reply #112290 as the answer for this post — 3 weeks ago
  • Page :
  • 1
There are no replies made for this post yet.