You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Wednesday, 16 November 2022
  8 Replies
  1.1K Visits
I have an issue that apparently cropped up back in the summer and was recently noticed. When saving a article with code pasted in JCE Pro (latest version but also several previous versions) is adding in a weird character of: Â which is added before every &nbsp and is visible to visitors and fills an article with junk. I prefer to use JCE Pro over TinyMCE but can't because of the junk it is adding.

TinyMCE has no issues with the code.

Here is an example code.
Original code:
<td valign="bottom"><p>Liontamer-Pazzazz Rothrock Tradition By Buddakan  </p></td>

Code when TinyMCE saves it:
<td valign="bottom">
<p>Liontamer-Pazzazz Rothrock Tradition By Buddakan </p>
</td>

Code when JCE Pro saves it:

<td valign="bottom">
<p>Liontamer-Pazzazz Rothrock Tradition By Buddakan </p>
</td>
more than a month ago
·
#112311
is adding in a weird character of: Â


JCE is not adding this character, what is happening is that Unicode content (which JCE generates by default) is being saved to a database table that is not set to support unicode (which it should be). This results in all utf-8 characters being stored as the  character.

One way you can try and fix this, is to download and install Admin Tools Core (free) - https://www.akeeba.com/download.html#admintools-joomla - and use the Change Databse Collation to set it to UTF-8 Multibyte. This won't fix existing articles that contain the  character, but should prevent it in future.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#112332
Appreciate the response.

I have an admin tools pro subscription so on your suggestion I ran the Change Database Collation to set it to UTF-8 Multibyte (recommended) which shows in the phpmyadmin as utf8mb4_general_ci collation (UCA 4.0.0, case insensitive). Then ran the suggested repair and optimize after.

I still get it on Docman. Specifically the docman_documents table field named description which is the description field of the document and uses the editor. This field also has the same collation as above and is a type of longtext.

Is there something I can turn off to prevent the update and the characters?

Thanks.
more than a month ago
·
#112340

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#112365
I am not able to replicate this issue on your site (in the testingjce article). Are there any other instances I should look at?

Furthermore, the places where the characters are occuring are all trailing spaces (a blank space at the end of a paragraph), which should probably not be there anyway, and are usually removed by the editor when the content is saved.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#112366
There is one category area of docman ( https://chowclub.org/ccci/breed-information/breed-statistics/2022-breed-standings) that is still doing the issue and is a docman breed statistics category, but everywhere else I checked is good so running the collation fix must have worked in most places. I'll just have to look deeper into what the issue is there.

I know they are trailing spaces and to get the data formatted I take the Word file given, put it in Dreamweaver, run Dreamweaver's fix Word file on it then copy paste the code into the description section and save the document. This is the same process that I use for most other articles as most are submitted by the club in Word or pdf to me to put on the website.
more than a month ago
·
#112367
I know they are trailing spaces and to get the data formatted I take the Word file given, put it in Dreamweaver, run Dreamweaver's fix Word file on it then copy paste the code into the description section and save the document. This is the same process that I use for most other articles as most are submitted by the club in Word or pdf to me to put on the website.


JCE does a pretty good job of fixing pasted Word content...

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#113559
I also have this issue with the docman docman_documents table description field and JCE.
I've also switched the encoding from utf8_general_ci to utf8mb4_unicode_ci.
In Joomla 4.2.9 JCE Pro 2.9.36 and Docman 4.



// double space anywhere
<p>testing testing</p>

// after save is
<p>testing  testing</p>

more than a month ago
·
#113560
I also have this issue with the docman docman_documents table description field and JCE.


Does this only happen in Docman? if so, then I suggest the issue is in Docman.

Have you tested this with the default Tinymce editor?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!