You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Thursday, 17 November 2022
  9 Replies
  108 Visits
I've created a link using Content option

The website link shows the page title https://www.thejungle.uk.net/training/fire-safety-awareness/fire-safety-awareness-first-page but the links just go to 404 - <p>We're sorry, that page doesn't exist or has moved!</p>
2 weeks ago
·
#112347
Accepted Answer
Confused this doesn't work either


I include the example to confirm that it is not a JCE issue, but to do with the whole Joomla menu / sef system.

It does add complexity, but using menu items is the best solution for stable SEF links.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#112330
If you create the link using the Article button below the editor, do you get the same 404 result?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#112335
I don't have an article button below the editor
2 weeks ago
·
#112336

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#112341
You have to create a menu item for each article you link to, otherwise the menu association (itemid) defaults to the Main Menu, and may result in a 404.

I have created the menu item for the article in question on your site, and updated the Next link with the new url.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#112343
That's not a good option as I'll have 6 submenus on my site.

These articles have been on my website for over 5 years. It's only when I went into it to change some text they stopped working. I've had quite a few gremlins like this since I upgraded to JCE Pro. Joomla should or did use to allow direct link to article content.

I'll probably just create a page break and condense the 6 articles I have into 1.

I've got quite a big site with lots of articles. I'm concerned it'll be broken elsewhere that I don't know about.
2 weeks ago
·
#112344
I've disabled the menu and reverted the link.

JCE using the Joomla API to create the links, so they are assumed to be correct. The Joomla Menu / SEF URL system is a complicated mystery, so JCE relies on the API to produce accurate links.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#112345
I've added the Article button at the bottom of the editor, which is a Joomla Core button for adding links to articles. If you use this to create the Next link, it creates an almost idential link (same id and catid but omits the alias values), which gives exactly the same 404 result when clicked.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#112346
Confused this doesn't work either
2 weeks ago
·
#112347
Accepted Answer
Confused this doesn't work either


I include the example to confirm that it is not a JCE issue, but to do with the whole Joomla menu / sef system.

It does add complexity, but using menu items is the best solution for stable SEF links.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

Lotty selected the reply #112347 as the answer for this post — 2 weeks ago
  • Page :
  • 1
There are no replies made for this post yet.