You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Monday, 21 November 2022
  7 Replies
  151 Visits
I have a problem: JCE converts the HTML symbols: < and > into HTML name inside SHORTCODE when switching form Code mode to Editor mode. Result: My pages do not work correctly, because the browsers read this as text.

Example in upload: shortcode_issue_1
Becomes in JCE Editor - see upload: shortcode_issue_2

What can I do to prevent this?
kuk changed the title from SHORTCODE issue - HTML symbols () are converted to HTML name to SHORTCODE issue - HTML symbols: "" are converted to HTML name — 1 week ago
kuk changed the title from SHORTCODE issue - HTML symbols: "" are converted to HTML name to SHORTCODE issue - HTML symbols are converted to HTML name — 1 week ago
1 week ago
·
#112390
Do you have the Protect Shortcode option enabled in Editor Profiles -> Editor Parameters -> Advanced?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

1 week ago
·
#112391
Yes, shortcode protection is enable (otherwise I would have a lot of trouble with all my shortcodes) :)

I have JCEv2.9.32
1 week ago
·
#112392
I just tested this issue with "Shortcode Protection" disable - and the effect isn't there anymore.

But this not really a solution for me, because without it I have other problems with codes inside a shortcode, which will be damaged when saving a page.
1 week ago
·
#112395
This seems to be working OK in my tests, but my test content may be a bit limited. Can you send me a login? - https://www.joomlacontenteditor.net/contact/site-login

Just because you're not paranoid doesn't mean everybody isn't out to get you.

1 week ago
·
#112397
I sent you the login.
1 week ago
·
#112408
Please try JCE Pro 2.9.33 Beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Clear your browser cache after install.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

1 week ago
·
#112421
Yes this fix it. Great! Thank you :)

Sorry for this late answer. Was very busy the last days.
  • Page :
  • 1
There are no replies made for this post yet.