You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Wednesday, 31 May 2023
  10 Replies
  561 Visits
JCE Editor is stripping Javascript from content when saved, so we looked at the settings for the profile (Default) and the "Allow Javascript" Advanced setting is set to No. But when we change it to Yes and then save the profile, the setting stays at "No", so we can't change it to "Yes". In fact, the same thing happens when we try to change "Allow CSS", "Allow PHP", and all the other toggle-buttons. We can change things like "Word Count Limit", and "File Browser List Size" in the Filesystem section, but none of the Yes/No button changes will save.

We are on JCE Pro v. 2.8.12 and logged in as a SuperUser. We use RSFirewall, but our IP is whitelisted.
more than a month ago
·
#113900
We are on JCE Pro v. 2.8.12 and logged in as a SuperUser.


Please update to the latest version of JCE Pro - https://www.joomlacontenteditor.net/downloads/editor/pro/latest

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#113905
Odd, there was no update notice in the admin like the rest of our sites. But the version is now updated to 2.9.37 and we tried to "Allow Javascript" - still would not save.
more than a month ago
·
#113906
Which Joomla version are you using? Assuming it is Joomla 3, are you using the latest version of Joomla 3? (currently 3.10.11)

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#113913
Yes, Joomla 3.10.11.
more than a month ago
·
#113915

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#113938
I think this has something to do with changes you hav emade to the admin template. When a Radio button option is changes, eg: Yes / no in the Allow Javascript option, it is not correctly triggering the onchange event on the hidden radio input element.

As this works in all other instances I have seen and tested, I can only conclude that the issue might lie with the admin template.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#113939
Would it be possible to add the default Joomla 3 "Isis" template to your site and test with that?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#113941
Odd, we can see all the Isis files on the site (see attached) but it doesn't show up as an option for the Admin Templates. Any idea how to resolve that?
more than a month ago
·
#113942
Go to Extensions -> Manage -> Discover, and click the Discover button to find the Isis template. Select it, the click Install.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#113943
It is working now with the Isis template. We will investigate the issue with the custom template. Thanks!
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!