You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)
  Saturday, 08 July 2023
  4 Replies
  767 Visits
Hey, I've always used JCE as my Joomla editor, in my prior Joomla 2.5 and 3 sites. I am now switching everything over to Joomla 4. I see that JCE Pro is still installed (the most current version) within the components installed in my newly migrated Joomla 4 sites. However, it does not show up in the selector dropdown as an option to select. I only see "None," "CodeMirror," and "Tiny MCE" as options for selection. This is both the case in Global Configuration, and also in the specific editor settings for each User.

How can I get Joomla 4 to recognize JCE, and present this as an option to use as my editor?
more than a month ago
·
#114148
In the meantime - not having access to JCE for a few days reminded me how much I love and rely on JCE - a mainstay I've used for many years. Grateful to be able to keep using this wonderful program in Joomla 4 now! :-)


Thank you! :D

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114147
Yes - I learned yesterday that the migration extension I used disables extensions intentionally, and tells you to re-enable them after migration. So yes - this was the correct process.

In the meantime - not having access to JCE for a few days reminded me how much I love and rely on JCE - a mainstay I've used for many years. Grateful to be able to keep using this wonderful program in Joomla 4 now! :-)
more than a month ago
·
#114144
3) Checked Joomla 4 Extensions, searching "JCE." Found 7 JCE plugins - all but 2 were disabled. Enabled all 7 of them.


This is what caused the initial issue. I'm not sure why they were disabled, I assume it may have happened in the site migration.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114142
Looks like I found my own answer here - posting it for the benefit of others:

1) Joomla 4 dashboard prompted me that I needed to enter the Download key for JCE (apparently this didn't transfer over from the Joomla 3 site.)
2) Found the Subscription key in My Account in JCE - pasted it in as the Download key in Joomla 4.
3) Checked Joomla 4 Extensions, searching "JCE." Found 7 JCE plugins - all but 2 were disabled. Enabled all 7 of them.
4) Then went back to Global Configuration - finally JCE appeared in the editor selector dropdown. Selected it - and JCE is working on my sites again!

Hope that's helpful for others that might encounter the same disruption of JCE, in transferring to Joomla 4.

PS: This article (the Joomla 4.x section) was useful in figuring this out:
https://www.joomlacontenteditor.net/support/faq/subscription/using-the-subscription-key
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!