You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Friday, 25 August 2023
  16 Replies
  695 Visits
Hello,

I try to use the JCE add columns feature. But the created columns are not displayed as vertical columns in the editor, but as paragraphs one below the other (also in Preview). After publication, the columns are aligned vertically. However, this is cumbersome for creating and changing the columns. Any idea to change that?

Editor Global Configuration - Editor Styles option is set to Template CSS File. JCE Version 2.9.41

Kind regards,
Wolfgang
more than a month ago
·
#114534
Accepted Answer
The editor.css file is present, and includes the invalid @import rule:

https://cdn.joomlacontenteditor.net/tmp/114498-not-correct-css-representation-of-columns-in-jce-editor.jpg

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114499
but as paragraphs one below the other (also in Preview). After publication, the columns are aligned vertically. However, this is cumbersome for creating and changing the columns.


This is because the width of the editor may be different to the width of the front-end article display, so the Columns Stack Width comes into effect in the editor, stacking the columns.

When inserting Columns, experiment with the Stack Width option to see which works best for your situation. Setting it to Small might be a good place to start.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114514
Yes I see, clarified as far as the columns are concerned. However, JCE Editor does not take the defaults from the template with regard to font sizes, fonts, headings and other CSS settings.

Editor Global Configuration - Editor Styles option is set to Template CSS File.
more than a month ago
·
#114515
Editor Global Configuration - Editor Styles option is set to Template CSS File.


Which template are you using?

Is the Editor Global Configuration -> High Contrast Mode option set to No or Auto?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114520
Editor Global Configuration -> High Contrast Mode option is set to No.

Template: A Rockettheme template named Citadel
more than a month ago
·
#114521

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114522
Of course, done.
more than a month ago
·
#114524
Your site had an editor.css file which was incorrectly attempting to load the custom_13.css file for your template.

JCE now automatically loads the required template stylesheets for most major template frameworks including gantry so your editor.css file is no longer needed, unless you want to load only very specific files. I deleted the editor.css file on your site and the content styling issue is resolved.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114526
Thank you very much! Could you please tell me, where this editor.css was located exactly. I'm currently working on a test server with a website copy on migrating to joomla 4 . I didn't find there any corresponding file to delete in /htdocs/components/com_jce or in the template section that this support article pointed to.
more than a month ago
·
#114527
The editor.css file was in the templates/rt_citadel/css folder.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114528
OK, in joomla 4 there is no such editor.css in that folder (screenshot attached). And I didn´t choose one in JCE Administration -> Global Configuration.
There was such a file in a scss folder below. I deleted it, but it didn´t help to get template stylesheets into the editor.
more than a month ago
·
#114529
Also check in the custom/css-compiled/ folder.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114530
Checked, no editor.css file there
more than a month ago
·
#114531
Is this a diiferent site to the one you sent the login for? If it is, please send me a new login -> https://www.joomlacontenteditor.net/contact/site-login

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114532
Different site with content of original site - joomla 4 Testserver. Login sended
more than a month ago
·
#114534
Accepted Answer
The editor.css file is present, and includes the invalid @import rule:

https://cdn.joomlacontenteditor.net/tmp/114498-not-correct-css-representation-of-columns-in-jce-editor.jpg

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114537
Right. Sorry, I dont´t know what went wrong this morning. Deleted again and it works. Thanks again!
hundenarr selected the reply #114534 as the answer for this post — 6 months ago
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!