You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Tuesday, 29 August 2023
  2 Replies
  714 Visits
Joomla 3.10.12 and 4.3.4
PHP 8.1
JCE Editor Pro 2.9.41 and 2.9.40
Astroid Framework / Templates by Joomlaplates


I want to use the HTML element <details> with <summary>.
Because this element is not included in the format select list I write it in code view.

Code example

<details>
<summary><strong>Lindemanns Pablo</strong></summary>
<p><strong>170/17A 73532 SP, </strong>bwB, gew. 09.04.2017,66 cm, sg /v/sg Auge  mittel</p>
</details>



Now, a strange incident occurs - you can see it in the video.

When I change to editor view (e.g. for editing) and go back to code view (e.g. for inserting another code block) the editor wraps the <details> block with a paragraph element AND also inserts empty paragraphs before and after.
What's more, just switching to the editor view will create the wrap and the empty paragraphs.

It doesn't happen with the TinyMCE editor
AND
it doesn't happen when I put each <details> block in a <div> container.

I don't expect you to start looking for the error right away.
The workaround is easy especially using the great snippets feature.
Maybe someday you will have the time or desire to get to the bottom of the problem. (See your answer in /forum/108314-icons-for-using-html);)

Ute
more than a month ago
·
#114525
Accepted Answer

Just because you're not paranoid doesn't mean everybody isn't out to get you.

UteS changed the title from Error with HTML element to Error with HTML details element — 6 months ago
more than a month ago
·
#114525
Accepted Answer

Just because you're not paranoid doesn't mean everybody isn't out to get you.

UteS selected the reply #114525 as the answer for this post — 6 months ago
more than a month ago
·
#114538
Hello Ryan,

it works.
Thank you very much for the quick help and the perfect solution!

Ute
:D
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!