You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  Thursday, 31 August 2023
  2 Replies
  470 Visits
Hi!
I have a strange error after update to Joomla 4.
If an image with Swedish characters (åäö) in the filename is used, the article is saved superslow and the page end up with an 500 error.

And even stranger is that it only occurs for Publishers and not for Supersusers like me....

Do I miss any setting?

Kind regards
Matt
J4.3.3
JCE 2.9.41
PHP 8.1
more than a month ago
·
#114543
Accepted Answer
Thanks for the quick reply!

Good to know that a solution is close.

Kind regards
Matt
more than a month ago
·
#114542
If an image with Swedish characters (åäö) in the filename is used, the article is saved superslow and the page end up with an 500 error.

And even stranger is that it only occurs for Publishers and not for Supersusers like me....


This is because the issue is caused by the Joomla Text Filter processing the content on saving. The Text Filter settings for Super USer are probably set to No Filtering, but for the Publisher user group they are set to Default Blacklist, so the content is filtered when saving. This process appears to be stalling on content that contains special characters in attribute values, like the url in the img tag src attribute.

This has been reported and appears to be on the way to a fix, perhaps in the next Joomla update - https://github.com/joomla/joomla-cms/issues/39515

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114543
Accepted Answer
Thanks for the quick reply!

Good to know that a solution is close.

Kind regards
Matt
ucr selected the reply #114543 as the answer for this post — 5 months ago
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!