You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. wdburgdorf
  2. JCE Editor
  3. Sunday, 15 November 2015
Hi,

I spent some time trying to get an iframe into an article, no luck. I read what I found in this forum, and some googling. HTML cleaning switched off everywhere for anyone, iframe plugin installed etc. One success: iframes are not already stripped when toggling editor. But after saving an article, it's gone.

Joomla 3.4.5, JCE 2.5.11


EDIT:
I tested some more:
Standard article: When toggling the editor, all attributes are removed. Saving the article, the iframe will not be stripped - so as long as I don't toggle, it's ok.
Text in JEvents: attributes removed on toggle, iframe stripped on save.
Accepted Answer
Accepted Answer Pending Moderation
Standard article: When toggling the editor, all attributes are removed. Saving the article, the iframe will not be stripped - so as long as I don't toggle, it's ok.


In Editor Profiles -> Editor Parameters -> Advanced, have you added anything to the Extended Elements list? If you have added "iframe", remove it.

Text in JEvents: attributes removed on toggle, iframe stripped on save.


JEvents may have additional options for text filtering, that is removing the iframe. Check the JEvents configuration.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # Permalink
Accepted Answer Pending Moderation
Thanks, Ryan.

> If you have added "iframe", remove it.
I tried both, no difference. Currently the field is empty.
Why would adding something to Extended Elements filter something out? I thought it was supposed to do the opposite?

> JEvents filtering
Indeed, there is a setting "Allow unfiltered descriptions" (Config > Event editing)

I switched this on, and now everything seems to work. I don't see how this could be related to standard articles. And now, switching the filtering back on for JEvents, standard articles are still fine.
Strange, but for the time being the issue seems solved. thanks again.
  1. more than a month ago
  2. JCE Editor
  3. # 1
Accepted Answer Pending Moderation
Why would adding something to Extended Elements filter something out? I thought it was supposed to do the opposite?


Adding just iframe to this field (which some users do), allows the iframe tag only, without any attribtues. The correct syntax is iframe[src|frameborder|width|height] etc.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 2
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!