You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. ulrabd
  2. JCE Editor
  3. Wednesday, 08 June 2016
After upgrade I get this error when trying to open any content article,
and when clicking "File Browser" on JCE Administration :: Control Panel

Parse error: syntax error, unexpected '[' in /website-directory/components/com_jce/editor/libraries/classes/extensions/filesystem.php on line 120

My system:
Joomla! Version: Joomla! 3.5.1 Stable
PHP Version: 5.3.29

JCE Plugins:
File Manager 2.1.9
Image Manager Extended 2.0.33
Media Manager 2.0.16

System - JCE MediaBox 1.2.3

Can I just (re-) install the JCE 2.5.16 extension over JCE 2.5.17 to quickly circumvent the Problem?

Regards Ulrich
Accepted Answer Pending Moderation
I have also this problem, only occurs in PHP 5.3.19, higher versions don't show this error.
  1. more than a month ago
  2. JCE Editor
  3. # 1
Accepted Answer Pending Moderation
Same issue.
Cannot edit anything with JCE Editor shown - whole layout is broken
Downgrade to 2.5.16 solved problem
Joomla 3.5.1, PHP 5.3.29
  1. more than a month ago
  2. JCE Editor
  3. # 2
Accepted Answer Pending Moderation
Suggestion to fix:

File:
/components/com_jce/editor/libraries/classes/extensions/filesystem.php


Change from line 119/120 to :
// get the first group
$group_id = array_keys($groups);
$group_id = $group_id[0];
  1. more than a month ago
  2. JCE Editor
  3. # 3
Accepted Answer Pending Moderation
Tried Buro26's suggestion. Lines 119-122 now look like this:
// get the first group
$group_id = array_keys($groups);
$group_id = $group_id[0];
// Joomla! 2.5?

Sorry, unfortunately still same error
  1. more than a month ago
  2. JCE Editor
  3. # 4
Accepted Answer Pending Moderation
You can re-install JCE 2.5.16 to resolve this error.

Alternatively, and preferably, get your host to upgrade your server to PHP 5.5 or later!!!
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 5
Accepted Answer Pending Moderation
Ryan, thank you, obviously PHP 5.5 or higher is the way to go.
Tried PHP 5.5 just now, but got an other error: Joomla could not connect to MySQL..
So will try re-install JCE 2.5.16 as quick solution, and work on all prerequisites for switch to a more current PHP-version when back at home (currently on a Greek camping).
  1. more than a month ago
  2. JCE Editor
  3. # 6
Accepted Answer Pending Moderation
Tried PHP 5.5 just now, but got an other error: Joomla could not connect to MySQL..


As PHP 5.5 is EOL next month, you should only be considering PHP 5.6 or PHP 7 - http://php.net/supported-versions.php
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 7
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!