You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. Jentoo
  2. JCE Editor
  3. Sunday, 27 November 2016
Hello

I just upgrade JCE editor to 2.6 and now can no longer view source code in k2 custom tabs. There is no toggle button on these for source but previously I could access it through the source code button.

I have a subscription so I looked at installing add-ons, but this feature is now also missing. Then I downloaded and installed the pro version of jce but I still have no option for the addons, and still have no source code button. Am I correct in thinking these have now been made part of the pro installation and no longer need to be installed separately?

I looked at adding the button through the editor profile settings under Available Buttons & Toolbars but I can't see the icon that I have on my previous JCE installations, and there's no clue as to what the additional icons are like in a tooltip.

How can I retrieve this button?

Thanks
Jennie
Accepted Answer Pending Moderation
Yeah, noticed that too. You have to use the tabs now, but I'd rather have the button back.
  1. more than a month ago
  2. JCE Editor
  3. # 1
Accepted Answer Pending Moderation
I can see a button that switsches between rich text and HTML view. But I do not like the style of this button. In my opinion this is a Windows 10 shutdown or power off button. See attachment. What do you think?
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 2
Accepted Answer Pending Moderation
Also that button gives an un-color coded version of the code, like looking at it in a plain text editor.
  1. more than a month ago
  2. JCE Editor
  3. # 3
Accepted Answer Pending Moderation
I can see a button that switsches between rich text and HTML view. But I do not like the style of this button. In my opinion this is a Windows 10 shutdown or power off button. See attachment. What do you think?


This button does turn the editor off, exactly the same as the old [Toggle Toolbars] link.

You can access the Source Code Editor by clicking on the Code tab on the right, above the toolbar.

https://cdn.joomlacontenteditor.net/tmp/jce-tabs.gif
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 4
Accepted Answer Pending Moderation
@Ryan: I still think, that this button is illogical and not self-explanatory. It looks very much the same like the Windows 10 shutdown button. Apart from this secondary issue: what is wrong if I do not see the [Editor] [Code] [Preview] tabs?
  1. more than a month ago
  2. JCE Editor
  3. # 5
Accepted Answer Pending Moderation
Apart from this secondary issue: what is wrong if I do not see the [Editor] [Code] [Preview] tabs?


Is this happening in the Joomla Article Manager, or some other extension?
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 6
Accepted Answer Pending Moderation
Hi,

you can change that button by any other user friendlier button, when renaming the file: "power..png" to "power-old.png" and load up a file of your choice with the name of "power.png".

This all must be done in the directory: /components/com_jce/editor/libraries/img/ of your webserver.

!!! This must be done, all the time, when the file is being overwritten by a new jce-software-update.

The most beautiful way is, when Ryan will make the icon to be user-configured via the jce-options;)
  1. more than a month ago
  2. JCE Editor
  3. # 7
Accepted Answer Pending Moderation
My problem is I relied on the button in my k2 tabbed items using SWtabs pro by Styleware. The toggle option was never available in the editor here (see attachment) so now the button has gone, it is no longer possible to access the source code.

:(
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 8
Accepted Answer Pending Moderation
I've attached shot of the missing button for clarity.
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 9
Accepted Answer Pending Moderation
Ryan: Is this happening in the Joomla Article Manager, or some other extension?

This is happening in the Joomla article manager. See attached screenshot.
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 10
Accepted Answer Pending Moderation
@crimle - In Editor Profiles -> Features & Layout -> Additional Features, are the Preview Tab and Source Code Tab options checked?

https://cdn.joomlacontenteditor.net/source-code-button-missing-after-upgrade.png
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 11
Accepted Answer Pending Moderation
These options were NOT checked. I can see the tabs now. The issue is resolved, although I do not know why these options were not checked by default. Thank you for your help.

Kind regards
crimle
  1. more than a month ago
  2. JCE Editor
  3. # 12
Accepted Answer Pending Moderation
My Source Code Tab options are checked and I still do not see that button attached. Where did it go? I just did the latest update too
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 13
Accepted Answer Pending Moderation
My Source Code Tab options are checked and I still do not see that button attached. Where did it go? I just did the latest update too


The Source Code view is accessed by clicking the Code tab above the editor toolbar on the top right. See my post above - https://www.joomlacontenteditor.net/support/forum/source-code-button-missing-after-upgrade#reply-87264
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 14
Accepted Answer Pending Moderation
That tab you referenced does not do what that old button used to do. See image attached. It does not highlight and organize the code for you like that button did.

It just gives an un-color coded version of the code, like looking at it in a plain text editor.
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 15
Accepted Answer Pending Moderation
It does not highlight and organize the code for you like that button did.


You do not have JCE Pro installed.

Please install JCE Pro 2.6.2 Beta - https://www.joomlacontenteditor.net/downloads/editor/pro/item/jce-pro-262-beta-2
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 16
Accepted Answer Pending Moderation
It is now working properly. Thank you
  1. more than a month ago
  2. JCE Editor
  3. # 17
Accepted Answer Pending Moderation
Mine is not working properly at this point. When I go into the code tab, there are a set of buttons at the top left. I cannot click on those to use them. In addition, I cannot type anyting in the "search" or "replace" boxes. It's like all the buttons are stuck, and I can't control it. If I press the new on-off button, then the code goes into plain text and I do not have any tools or the search and replace options at all.

I have further information: The "stuck buttons" appear to be associated with the Safari browser. When I try in Chrome, it is working better.

But, I am also one that wants my button for code back. With the tabs on the far right, I have to move my mouse farther to the right. This may not seem like much, but as one who has had carpal tunnel surgery, and updates 4 sites several times daily, that extra mousing adds up to a very achey arm.

So, to sum up, I'd like the option to have the button back, and I need it to work in Safari.
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 18
Accepted Answer Pending Moderation
Mine is not working properly at this point. When I go into the code tab, there are a set of buttons at the top left. I cannot click on those to use them. In addition, I cannot type anyting in the "search" or "replace" boxes. It's like all the buttons are stuck, and I can't control it. If I press the new on-off button, then the code goes into plain text and I do not have any tools or the search and replace options at all.

I have further information: The "stuck buttons" appear to be associated with the Safari browser. When I try in Chrome, it is working better.


I've tested this using Safari (latest) on the demo site and it is working - http://demo.joomlacontenteditor.net/

Do you have the same issue on the demo site?
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 19
Accepted Answer Pending Moderation
Yes, I have the same problem on the demo site.

I am using:

MacOS Sierra, 10.12.1

Safari, 10.0.1

iMac, Late 2014; 32 GB, 3.5 Ghz Intel Core i5.

Lynne
  1. more than a month ago
  2. JCE Editor
  3. # 20
Accepted Answer Pending Moderation
MacOS Sierra, 10.12.1

Safari, 10.0.1


This is working consistently for me in Safari 10.0.1 on MacOS Sierra 10.12.1 on the demo site.

Do you have any browser extensions running in Safari that could possibly be causing an issue?
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 21
Accepted Answer Pending Moderation
Ryan, that was it! Great call.

I had the Grammarly extension installed in Safari. When I turned that off, the issue went away.

I like what Grammarly tries to do, but it's been problematic on other things, too. So, I'll turn it off and all will be well.

Thank you so much!

Lynne

(But, I'd still like the option to have the button in the tool bar if possible. Cheers!)
  1. more than a month ago
  2. JCE Editor
  3. # 22
Accepted Answer Pending Moderation
I like what Grammarly tries to do, but it's been problematic on other things, too. So, I'll turn it off and all will be well.


I too would like to see it work with JCE. When I get a chance I will look into what is causing the conflict.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 23
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!