You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  Sunday, 08 January 2017
  18 Replies
  5.1K Visits
Hi, I am using Joomla! 3.6.5 and JCE Pro 2.6.6. I updated to JCE Pro because I had a problem, but I still have the same problem. If I click on the link icon and get the links popup window, then click on the files icon to link a PDF, I don't see my folders. I only see Home. If I go through the images folder, everything is good. I have been using JCE since around 2010 and never had any problems with anything like this. I have not changed the path to the images folder. Everything is still the default. Help.
more than a month ago
·
#89098
In Editor Profiles -> Plugin Parameters -> Link, is "Language Direction" set to "Left To Right" or "Right To Left"?

If it is, set it to "Not Set" and save the profile.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#89109
Hi, I checked it. It was not set at all. I created a new profile and it doesn't have this problem, so it is obviously a pref somewhere that is set. I can't re-install the app because I am also having max-memory issues. I am thinking about just re-installing Joomla from scratch and re-doing. This is just a sandbox right now so it doesn't matter. I have only encountered this problem in this site. I am using Pro in my other sites and all is well. Love the redesign. Thanks for your help.
more than a month ago
·
#89110
I had this problem too....I think the answer is that the browse button is less conspicuous now.

http://www.gbasites.net/_img/JCE-browse-button.png
more than a month ago
·
#89111
I found the button and have been using it. The problem is after I click on it, I can't see the folders in the file browser. I only see HOME. What is odd is that I created a new test folder and I can see that. It is like I am in a totally different place from my regular images folder. I did find this neat new insert/edit file button. It is harder to use but it worked for now. I just needed to link some PDF files from an article.
more than a month ago
·
#89112
@pachi - Please select the problematic profile in the Editor Profiles list, then click the Export button.

Download the profile xml file, zip it, and post it here as an attachment, so I can have a look at it.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#89114
That's awesome, I forgot I could do that. I can just take one from another site and import it. Duh! Here is the file. Thanks. I am sure it is something I clicked on.
more than a month ago
·
#89124
I have fixed the profile (removing a "dir" entry for the Link plugin, which refers to language direction and not File Directory Path). See attached zip.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#89186
Hi, So, is this something I could just do to my other sites? Or, just, replace all of the user profiles with this one, for now?
more than a month ago
·
#89209
If the other sites are experiencing the same issue, then use the fixed profile above.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#89215
I have the problem to create links to .html or .htm-files. They are not listed in the file-browser. I updated jce from 2.6.6 pro to 2.6.7 rc2 pro. With both versions the same problem
more than a month ago
·
#89216
I have the problem to create links to .html or .htm-files. They are not listed in the file-browser.


html and htm files are not displayed by default. You can add them in Editor Profiles -> Editor Parameters -> Filesystem.

Click on File Browser, then on the edit icon next to Permitted File Extensions. See below.

https://cdn.joomlacontenteditor.net/tmp/problem-linking-to-pdf-through-link-file-browser.gif

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#89220
I did so. html and htm files are added. But. If i click the file-browser in the control center I can see the html-file (screen_1).
If I click the search-button in link-manager I can't see it (screen_2). I used formerly jce 2.5.x for a long time and never had the problem.
Hope you can help me. Otherwise I have to insert the links using copy and paste (filezilla).
more than a month ago
·
#89261
Replace browser.php in /components/com_jce/editor/tiny_mce/plugins/browser/classes/ with the file in the attached zip.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#89268
Thank you very, very much. Problem is solved.
more than a month ago
·
#89279
Thanks for all your help. I am now using the profile you sent me and all is well.
more than a month ago
·
#111744
Ich habe das gleiche Problem, bei mir fehlt aber der ordner /classes

Wie kan ich das Problem dann lösen?
more than a month ago
·
#111752
Ich habe das gleiche Problem, bei mir fehlt aber der ordner /classes

Wie kan ich das Problem dann lösen?


Do you have the latest version of JCE Pro installed? The solution above on longer applies.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#112488
Hello,
I do have the same problem, and yes, the latest editor version is installed.
The directory classes, as you pointed out in: /components/com_jce/editor/tiny_mce/plugins/browser/classes/
is not existing.
This is in Joomla3 and Joomla4
Now what?

Kind regards,
Gerard
This email address is being protected from spambots. You need JavaScript enabled to view it.
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!