You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. jboulton
  2. JCE Editor
  3. Thursday, 27 April 2017
Hello,

When I submit a news article through the front end of the website I get a Warning Empty solution not allowed. I can submit the news article through the backend.

Joomla 4.7
Latest JCE Pro
PHP 7

I turned on the development error settings and I didn't see any errors.

Thanks.

Jeff
Accepted Answer Pending Moderation
Same problem for me

Joomla 3.7.0
php 7
jce pro 2.6.12

Thanks

Robert
  1. more than a month ago
  2. JCE Editor
  3. # 1
Accepted Answer Pending Moderation
I do get a few js errors:

Error parsing header X-XSS-Protection: 1; mode=block, 1; mode=block: expected semicolon at character position 14. The default protections will be applied.
  1. more than a month ago
  2. JCE Editor
  3. # 2
Accepted Answer Pending Moderation
This is a captcha conflict
Disable the default capcha and it's working !
  1. more than a month ago
  2. JCE Editor
  3. # 3
Accepted Answer Pending Moderation
Thanks i-media. I tried that, now I get:
Error:
0 - Call to a member function checkAnswer() on null

I have a feeling this is a template issue.

Jeff
  1. more than a month ago
  2. JCE Editor
  3. # 4
Accepted Answer Pending Moderation
Do yo get the same error with the Tinymce editor?
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 5
Accepted Answer Pending Moderation
Yes. Same error with Tinymce editor !!
  1. more than a month ago
  2. JCE Editor
  3. # 6
Accepted Answer Pending Moderation
Same here, 3.7 and 2.6.8. Looks like 3.7 must have changed something.
  1. more than a month ago
  2. JCE Editor
  3. # 7
Accepted Answer Pending Moderation
I'm having the same issue. Is is Joomla 3.7 or the latest JCE update? I'm unable to edit pages from the front end - this is a disaster! This needs fixing asap.
  1. more than a month ago
  2. JCE Editor
  3. # 8
Accepted Answer Pending Moderation
I updated to 3.7 and PHP7 and I can not edit on front end either. Also I am getting the following error when trying to edit in back end.

Fatal error: Switch statements may only contain one default clause in /home/www/http://exploreatlanticcanada.ca/components/com_jce/editor/libraries/classes/document.php on line 279
Gary
  1. more than a month ago
  2. JCE Editor
  3. # 9
Accepted Answer Pending Moderation
The fix for me was to disable captcha-recaptcha in the global config and enable it in the contact options. After disabling it in the global config the error was gone.

Dan.
  1. more than a month ago
  2. JCE Editor
  3. # 10
Accepted Answer Pending Moderation
Disabling the global Recaptcha fixed one site and I also had to turn off progressive caching on another site.

I switched to Tinymce editor and received the same issues so this is a Joomla issue.

Jeff
  1. more than a month ago
  2. JCE Editor
  3. # 11
Accepted Answer Pending Moderation
I updated to 3.7 and PHP7 and I can not edit on front end either. Also I am getting the following error when trying to edit in back end.

Fatal error: Switch statements may only contain one default clause in /home/www/http://exploreatlanticcanada.ca/components/com_jce/editor/libraries/classes/document.php on line 279
Gary


@Simwombat - this is a completely different issue to the one originally posted, and yours can be easily solved by upgrading to the latest version of the editor - https://www.joomlacontenteditor.net/downloads/editor/item/jce-pro-2-6-12
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 12
Accepted Answer Pending Moderation
As from 3.7 it appears that captcha can be enabled at article level and although by default 'Allow Captcha on submit' is set to 'None Selected' it is in fact enabled.

The fix is to go to Content | Articles | Options and click on the 'Editing Layout' tab and click 'Save'

article-captcha-setting.jpg

Trevor
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 13
Accepted Answer Pending Moderation
Thanks trevorsm !
This method also works for me !
  1. more than a month ago
  2. JCE Editor
  3. # 14
Accepted Answer Pending Moderation
Thank you for posting this question. The solution of setting "Allow Captcha on submit" to "None Selected" worked for me too.

In our website's case, when I edited the article by logging in to the Joomla back end and using JCE from there, I did not see any error message and could save articles just fine.

However if I edited the article by logging in to the website FRONT END and editing the article by hitting the edit icon, THEN I got the error message (but no more, after applying the fix).

I edit from the "back end" but my user who reported the problem edits from the front end, so I didn't know about the problem right away.
  1. more than a month ago
  2. JCE Editor
  3. # 15
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!