You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Monday, 27 November 2017
  12 Replies
  11K Visits
Hi Forum

I'm using JCE-editor pro for Taurus.dk

When enabled the file-browser coming from JCE-editor, no images are shown when trying insert an image.

Screenshot from the inspector is added - and its becuse of "field-media-modal" in media.php.

How can this be fixed?
more than a month ago
·
#94256
Accepted Answer
You will need to remove


filter="raw"


or replace it with


filter="images"


or


filter="files"

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#94241

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#94242
Hi Ryan

Added now. Just add /administrator to the URL to access the backend.

Thanks.
more than a month ago
·
#94243
Which part of the site is this not working in?

I have tested editing an article, and the JCE File Browser is shown when launched from the "Images & Links" tab, and from JCE dialogs.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#94244
Hi Ryan

Component -> Udlejning -> Ledige lejemål (Means 'Available listings)

Just pick one of them - see attached for example.
more than a month ago
·
#94245
It looks like there was some kind of issue with the Compression Options. After setting Compress CSS and Compress Javascript to No in the Editor Global Configuration, the File Browser is now loading as expected.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#94246
Hi Ryan

Images are still not shown in the file-browser?
more than a month ago
·
#94247
It looks like the component is adding resetting the filter variable in the File Browser url from the default of &filter=images to &filter=raw, which is telling the File Browser to only display files of the type "raw"

Is this a custom component?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#94251
Hi Ryan

First of all, thanks for not unpublishing the file browser again as i told you to, if you could not get it to work. Now my client haven't been able to upload any images since yesterday, ans are pissed.

And yes, it is a custom module.
more than a month ago
·
#94252
In the form xml file for the component, have you set a filter attribute for the "media" field entries, eg (from com_content):

<field
name="image_intro"
type="media"
label="COM_CONTENT_FIELD_INTRO_LABEL"
description="COM_CONTENT_FIELD_INTRO_DESC"
filter="images"
/>

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#94255
Hi ryan

<field name="billede1" type="media"

label="COM_UDLEJNING_FORM_LBL_LEDIGE_LEJEMAAL_BILLEDE1"
description="COM_UDLEJNING_FORM_DESC_LEDIGE_LEJEMAAL_BILLEDE1"


required="true"
menu_published="0"
filter="raw"
directory="udlejning"
option_on="Yes"
option_off="Yes" />

The thing is - i assume the reason for using the raw-filter is because of the generated XML-file another site uses to crawl all the information about the available listings.
more than a month ago
·
#94256
Accepted Answer
You will need to remove


filter="raw"


or replace it with


filter="images"


or


filter="files"

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#94293
Hi Ryan

Thanks, worked like a charm :)
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!