You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. toonetcreation
  2. JCE Editor
  3. Sunday, 07 October 2018
Hello,

I'm using many websites running on a sever with apache.
Now, I'm try to migrate them on another server running with Nginx.
On this new server I get this message when I open a joomla article :

Uncaught ReferenceError: WFEditor is not defined

And JCE editor is not displayed anymore.
I have found this solution on the forum :

In the Editor Global Configuration, set Compress Javascript and Compress CSS to No.

I have tried and works fine.
But my question is : why these settings where fine on my apache server and why now I need to turn them off on my new nginx server?

Thanks
L.
Accepted Answer Pending Moderation
I have tested JCE Pro with NGINX with the compression options enabled, and it is working OK for me.

Try enabling the compression options, by make sure the Compress with GZip option is disabled.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 1
Accepted Answer Pending Moderation
I have tested and works with Gzip enabled and compression options disabled.

If Gzip is disabled and compression options enabled, editor is not displayed into joomla article.
  1. more than a month ago
  2. JCE Editor
  3. # 2
Accepted Answer Pending Moderation
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 3
Accepted Answer Pending Moderation
I have modified nginx configuration and modsecurity configuration and seems to be working fine.

I close this this ticket for the moment.

Many thanks
  1. more than a month ago
  2. JCE Editor
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!