You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Friday, 30 November 2018
  26 Replies
  11.2K Visits
Hi,

I am using J3.9.1, JCE 2.6.33 Pro and Helix Ultimate 1.0
In frontend editing I cannot open the JCE File Browser. I get an error 404.
I have activated the option "JCE File Browser in Image Fields". Clicking on any media type field or custom field type mediajce produces an error 404 in the popup.

There is already a quite long blog post in Joomshaper forum:
https://www.joomshaper.com/forums/create-article-in-frontent#reply-165460
Do you have an idea? How to solve that?

Thanks
Sigrid
more than a month ago
·
#97614
Accepted Answer
The Helix template includes an override for the media field - plugins/system/helixultimate/html/layouts/form/field/media.php - but it looks like there is an error in it.

From line 134 - 146 it reads:


<?php
$modalLink = '';

if(!$readonly)
{
if(!$link)
{
$modalLink .= 'index.php?option=com_media&view=images&tmpl=component&asset=' . $asset . '&author=' . $authorField;
}

$modalLink .= '&fieldid=' . $id . '&folder=' . $folder;
}
?>


but I think it should be:


<?php
$modalLink = '';

if(!$readonly)
{
if(!$link)
{
$modalLink .= 'index.php?option=com_media&view=images&tmpl=component&asset=' . $asset . '&author=' . $authorField;
} else {
$modalLink .= $link;
}

$modalLink .= '&fieldid=' . $id . '&folder=' . $folder;
}
?>

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#97605
Are you using an installed SEF extension, or Joomla SEF?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#97606
There is no SEF extensions.
if Joomla Core SEF is activated. --> Click on upload button --> modal with error 404
if Joomla Core SEF is deactivated --> click on upload button --> modal with homepage

I am using the custom field type "mediajce" in the frontend.
more than a month ago
·
#97607
Have you set any custom rules in the sites htaccess file?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#97609
hm, no, it is Joomla default htaccess
I renamed htaccess to htaccess.txt and i turned off all Joomla SEO params.
Then the modal file browser popup shows:
The requested URL /&fieldid=jform_com_fields_foto&folder= was not found on this server.

I tried to deactivated a few extensions/plugins, that might bring problems like admin tools
but still the same problem.
It works in protostar - so probably it is a bootstrap 4 issue.
How can i debug this - the site is in a dev environment online?
more than a month ago
·
#97610
BTW: Joomla default media browser field is working.
more than a month ago
·
#97611

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#97614
Accepted Answer
The Helix template includes an override for the media field - plugins/system/helixultimate/html/layouts/form/field/media.php - but it looks like there is an error in it.

From line 134 - 146 it reads:


<?php
$modalLink = '';

if(!$readonly)
{
if(!$link)
{
$modalLink .= 'index.php?option=com_media&view=images&tmpl=component&asset=' . $asset . '&author=' . $authorField;
}

$modalLink .= '&fieldid=' . $id . '&folder=' . $folder;
}
?>


but I think it should be:


<?php
$modalLink = '';

if(!$readonly)
{
if(!$link)
{
$modalLink .= 'index.php?option=com_media&view=images&tmpl=component&asset=' . $asset . '&author=' . $authorField;
} else {
$modalLink .= $link;
}

$modalLink .= '&fieldid=' . $id . '&folder=' . $folder;
}
?>

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#97618
Works great now! Thanks!!!

I will post a link to your solution to the Helix Forum as well. They need to urgently fix that.
more than a month ago
·
#101663
Hi !
Same issue here with Helix Ultimate, one year later.

So they haven't fixed their code :(

Txs for the solution Ryan !
more than a month ago
·
#103646
Hi,

After the last update of helix ultimate, they have changed the code inside: plugins/system/helixultimate/html/layouts/form/field/media.php and we have the same issue again. "In frontend editing, I cannot open the JCE File Browser. I get an error 404."

So, your above solution does not work, can you please check and see how to fix it?

Thank you.

Joomla 3.9.16
JCE: 2.8.9 pro
Helix-ultimate: 1.1.2
more than a month ago
·
#103648
So, your above solution does not work, can you please check and see how to fix it?


This can only be fixed in the Helix Ultimate template, using the same fix as I suggested above.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#106734
And here it is 2021 and I just had to do this fix.
more than a month ago
·
#106781
Ryan,

you are a hero. Thanks a lot for that fix!
more than a month ago
·
#106782
@blue_shift - me too.
sad that Joomshaper can't keep this right.

Ryan - as always - thanks for the great answer/support
more than a month ago
·
#106807
Hello Guys,

I seem to have the same problem, I see the solution here, but i can/t find the file in my back end that need top be fixed.
Can anybody help?

site : http://www.vtvvaals.nl

Thank Ed
more than a month ago
·
#106817
Hey Ed - it's in the solution above - plugins/system/helixultimate/html/layouts/form/field/media.php
more than a month ago
·
#106818
Dear Rod,

Thank you i have seen this, but i can't find the file where i have to edit the code.
The file media.php i'm trying to find, but i can;t find it.

CAn you direct me ?
more than a month ago
·
#106819
you need to FTP into your site - it's not accessible from within Joomla. Either through CPanel at your webhost or an FTP program
more than a month ago
·
#106820
oke, here is the layout of the ftp..where is the file?
From plugins/system i get lost
more than a month ago
·
#106821
it looks like you have helix3 installed - not helixultimate. see if the path continues inside helix3
more than a month ago
·
#106822
here is the tree inside Helix 3, there is no HTML directory
more than a month ago
·
#106823
check the layouts folder - poke around until you find the media.php file
more than a month ago
·
#106824
ok - after poking around in helix3 - the file and function don't exist. (no wonder you can't find it). This is a really old template - helix ultimate is so much better. I'd consider changing to be honest.
more than a month ago
·
#106826
but that would mean i have to change the whole layout of the site... its quite in use
more than a month ago
·
#106827
here is the content of the media.php file, can we do any change here?
more than a month ago
·
#106828
maybe someone else can fix the code for Helix3, but it's not a JCE problem. perhaps grab the solution above and post the question on JoomShaper. I don't see the issue in the media.php file (sorry)
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!