You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours
Monday to Friday
09:00 - 17:00 Europe/London (BST)

#114645 Special chars in file names in existing articles

Posted in ‘Editor’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Latest post by Ryan on Tuesday, 12 September 2023 14:17 BST

SigridGR
Hi,

I have seen more posts but not a really solution for me so far.
I have website with images and the filenames have special chars. This is due to historical reasons, it was update and is only for more than 10 years.

However, if I save an article in the backend where in the content is a file with special chars like "ö", get a max_execution_time error, but only if I don't have super admin-rights.
If I am Administrator, I get the error.
If I am Super User I don't get the error.
If I use Tiny MCE I don't get the error.
If I have JCE I get the error.

How can I solve this for existing articles when they are edited?
For new uploads the special chars are replaced, but we have a few hundred old images that are with specials chars and these images are within the joomla article text.

I added the profile below.

Any ideas how to solve this for existing articles?

Thanks
Sigrid

Attachments

Ryan
If I am Administrator, I get the error.
If I am Super User I don't get the error.


This is a Joomla bug in the TextFilter cleanup routine when the article is saved, which is why you get it with the Administrator and not the Super User (assuming the Administrator Text Filter option is set to Default Blacklist).

The issue has been reported - https://github.com/joomla/joomla-cms/issues/39515

If I use Tiny MCE I don't get the error.
If I have JCE I get the error.


Have you tested this with "No Editor"?

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.

Ryan

If I use Tiny MCE I don't get the error.
If I have JCE I get the error.


I've tested this with Tinymce, JCE and No Editor and in each case, a single image with special characters in the url will trigger the error, when the Text Filter options are set to Default Blacklist for the user.

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.

SigridGR
Did you change the Default Editor or the one for the user?
Because I just found a workaround.
If I set the global editor to tinymce and for the user to JCE, the error does not occur.

And it should be fixed with J5.0 - Thanks for the issue link.

Ryan
[quotePost id="114649"]Did you change the Default Editor or the one for the user?[/quotePost]

Default Editor in all cases.

Because I just found a workaround.
If I set the global editor to tinymce and for the user to JCE, the error does not occur.


I still get the error regardless of which way round this is set.

And it should be fixed with J5.0 - Thanks for the issue link.


Also in 4.4 I think.

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.