You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours
Monday to Friday
09:00 - 17:00 Europe/London (BST)

#117495 Invalid JSON response uploading

Posted in ‘Editor’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Latest post by Ryan on Thursday, 06 August 2026 16:50 BST

gavhanly

Hi - I've had this error start happening recently, and it seems linked to Sucuri firewall. I used to be able to upload images via JCE with no problem, but now it seems to have shut me out. I'm not sure what's changed, to be honest. 

I can get around this by going on a whitelisted static IP, but I have to change to that every time I want to upload something. 

Just wondering - have you come up against this problem with firewalls before, and is there a way to avoid this?

Ryan

I can get around this by going on a whitelisted static IP, but I have to change to that every time I want to upload something.

This is really the only solution, as the firewall does not llike the upload, and is blocking it, hence the JSON error. Do you have a log of why the firewall is blocking the upload?

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.

fujisan

I am encountering the same error as mentioned above.
Has this issue been resolved?

Current status of my site:
・The following error occurs when uploading an image, preventing the upload.

Joomla 6.1.2
JCE Pro 2.9.99.9
Image details: .jpg, 10KB

I have checked all MIME settings in both Joomla and JCE.
The server's WAF is also turned "off."
I contacted the server provider's support team, and they stated that no changes have been made recently.

Ryan

@fujisan - Please send me a login - https://www.joomlacontenteditor.net/contact/site-login

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.

gavhanly

For me, this is only a very intermittent issue now, works about 90% of the time. 

For those times it doesn't, going on a whitelisted static IP definitely solves the issue 100%. Not an ideal fix for everyone, but it is a way around it.  

fujisan

Thank you, gavhanly

I'd like to try your method, but how do you achieve "whitelisting" as you mentioned?

Thank you

gavhanly

First work out what your IP is, then add that to the Sucuri whitelist. If you don't have access to that, ask your host to do it for you. If your IP changes all the time (like mine does), you might need to get a static IP from something like NordVPN and get that whitelisted. That worked for me. 

fujisan

It is taking a long time to resolve this issue.
It appears to be quite a difficult problem.
Is there any workaround, such as deleting and reinstalling JCE?

 

Ryan

@fujisan - After 1 or 2 uploads on your site, all other uploads get a 403 error with the message: "The webmaster has forbidden your access to this site".

You may need to speak to your hosting company about this.

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.