You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours
Monday to Friday
09:00 - 17:00 Europe/London (BST)

Please create a new Ticket and we will get back to you as soon as we can.

#117730 PHP Fatal Error: Curly brace string offset syntax removed in PHP 8.0+ — s3.php line 2286

Posted in ‘Editor’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Latest post by Ryan on Wednesday, 10 June 2026 11:20 BST

despair

After upgrading to JCE Pro 2.9.99.6, the site throws a fatal compile error when opening any article for editing in the Joomla backend.

Root Cause:

Line 2286 of plugins/jce/filesystem-s3/s3/s3.php uses the curly brace string offset syntax ($value{0}), which was deprecated in PHP 7.4 and completely removed in PHP
8.0. This causes a fatal compile error before the file can execute.

Workaround:

Either of the following will resolve the error:

1. Disable the Amazon S3 plugin — Navigate to Extensions → Plugins, search for s3, and disable the Amazon S3 plugin (Type: jce, Element: filesystem-s3). The JCE
editor will function normally without S3 filesystem support.
2. Manual code fix — Replace $value{0} with $value[0] on line 2286 of plugins/jce/filesystem-s3/s3/s3.php.

 

- JCE Pro: 2.9.99.6
- Joomla: 4.4.11
- PHP: 8.3.30
- MariaDB: 10.11.16
- Web Server: nginx-fpm

Ryan

Please ensure you have the latest version of the S3 Object Storage plugin installed - https://www.joomlacontenteditor.net/downloads/plugins/editor/s3-object-storage-filesystem

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.