info

  • You need to be logged in to post in the forum - Log In
  • A subscription is required to post in the forum - Buy a Subscription
  1. mercer1122
  2. MediaBox
  3. Saturday, February 18 2012, 04:15 PM
Hi, I have had to make my box extremely wide to avoid having scrollbars show up - how can I adjust this? http://dev.spcai.org.

Thanks!
Ryan Accepted Answer Pending Moderation
This is the result of your template which assigns a default width of 960px to the base container element of the article.

As suggested in your other post you can perhaps deal with this by adding some css to one of the template's stylesheets, eg:

#jcemediabox-popup-ajax #rt-main-surround .rt-container {
width : auto;
}
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. MediaBox
  3. # 1
mercer1122 Accepted Answer Pending Moderation
OK, that fixed the width but I am still getting a vertical scroll bar. I tried setting "height" to auto as well.
  1. more than a month ago
  2. MediaBox
  3. # 2
Ryan Accepted Answer Pending Moderation
Your popup link appears to have a fixed width and height. The height is obviously not enough to contain the contents of the popup article :

<a type="text/html" rel="width[750];height[350]" class="jcepopup autopopup-multiple noicon" target="_blank" id="1230" href="/http://index.php/lightbox.html">
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. MediaBox
  3. # 3
mercer1122 Accepted Answer Pending Moderation
Unfortunately I am still getting vertical scrollbar. I have removed all width and height settings. My "close" button is also missing :( Please see

http://www.spcai.org/index.php?option=com_content&view=article&id=228

Click on the logo in the upper left corner of the article for popup.

Thanks!
Janet
  1. more than a month ago
  2. MediaBox
  3. # 4
Ryan Accepted Answer Pending Moderation
I'm not getting any scrollbars on the popup.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. MediaBox
  3. # 5
mercer1122 Accepted Answer Pending Moderation
I am getting it in Firefox, Safari and chrome on Mac. Please see screenshot.
Attachments (1)
  1. more than a month ago
  2. MediaBox
  3. # 6
Ryan Accepted Answer Pending Moderation
Try setting this rule in your template stylesheet :

#jcemediabox-popup-content #jcemediabox-popup-ajax {
overflow : hidden;
}
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. MediaBox
  3. # 7
mercer1122 Accepted Answer Pending Moderation
Thanks, that did the trick, just one other question, should the upper corners of my box be rounded too? Just the bottom two are rounded now. Appreciate your help.
  1. more than a month ago
  2. MediaBox
  3. # 8
Ryan Accepted Answer Pending Moderation
Have you made any changes to the JCE MediaBox css?
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. MediaBox
  3. # 9
mercer1122 Accepted Answer Pending Moderation
I redownloaded the component, replaced the css file, added the 3 lines from our previous conversations. The only remaining problem is that my radio boxes and check boxes do not show up in the pop up. They do show on the form page, though, so it must be a mediabox issue. I cannot find any css that may be affecting that. Once I solve this, I'll go away, I promise! :)
  1. more than a month ago
  2. MediaBox
  3. # 10
Ryan Accepted Answer Pending Moderation
replaced the css file, added the 3 lines from our previous conversations.


The css file additions I suggested in previous posts should not be added to the JCE MediaBox stylesheets, they should be added to your template's stylesheet.

Uninstall and re-install JCE MediaBox and add the css rules to your template stylesheet.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. MediaBox
  3. # 11
mercer1122 Accepted Answer Pending Moderation
Ok, I uninstalled, reinstalled, cleared cache. Still no checkboxes or buttons. :(
  1. more than a month ago
  2. MediaBox
  3. # 12
Ryan Accepted Answer Pending Moderation
Still no checkboxes or buttons. :(


If you are referring to the checkbox and button in the popup, they are showing for me in Chrome, FF, IE...
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. MediaBox
  3. # 13
mercer1122 Accepted Answer Pending Moderation
It turned out to be a BF form style issue. I just figured it out.
  1. more than a month ago
  2. MediaBox
  3. # 14
pixel Accepted Answer Pending Moderation
I used the plugins and editor for a many years. Sorry i have the same problem. What can i do.
I hope i`m understand you. My english is bad. Thanks Andreas
Attachments (1)
  1. more than a month ago
  2. MediaBox
  3. # 15
Ryan Accepted Answer Pending Moderation
Please post a link to an example popup.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. MediaBox
  3. # 16
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.