You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  1. holdsworthdesign
  2. JCE Editor
  3. Friday, 24 July 2020
Hi, With previous use of the editor, when I was pasting from a word document, it would retain the superscripted numbers. Now it only pastes the anchor tag with no number between it. Has something changed in the recent updates or is there a best practice that needs to be observed?
Accepted Answer Pending Moderation
There were some changes to improve security when pastinf external content, which may have inadvertantly affected other features.

Please attach an example document as a zip file that I can test with.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 1
Accepted Answer Pending Moderation
It happens with any word document with footnotes or endnotes. I've attached an example.
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 2
Accepted Answer Pending Moderation
This is working in my tests. Please post a screenshot of the Clipboard parameters in Editor Profiles -> Plugin Parameters -> Clipboard, or send me a login - https://www.joomlacontenteditor.net/contact/site-login
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 3
Accepted Answer Pending Moderation
Pay close attention to the numbers. The anchors appear fine, but the numbers get stripped out.
Attachments (1)
  1. more than a month ago
  2. JCE Editor
  3. # 4
Accepted Answer Pending Moderation
I also sent you login access if you need it.
  1. more than a month ago
  2. JCE Editor
  3. # 5
Accepted Answer Pending Moderation
I have fixed this on your site with an install of JCE Pro 2.8.16 Beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development - which adds a superscript tag for the footnote links.

It was also necessary on your site to add sup to the Keep Attributes field in the Clipboard parameters, where you had already add a list of tags. The footnote numbers were being removed initially on your site because this list did not include the span tag, which is no longer necessary.
Just because you're not paranoid doesn't mean everybody isn't out to get you.
  1. more than a month ago
  2. JCE Editor
  3. # 6
Accepted Answer Pending Moderation
Thank you!
  1. more than a month ago
  2. JCE Editor
  3. # 7
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!