You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  • Support
  • Forum
  • JCE Editor
  • File Directory Path Not working for File Browser, File Manager, Image Manager Extended, and Media Manager 06-26-2021

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Friday, 25 June 2021
  17 Replies
  3.5K Visits
The File Directory Path is not working for File Browser, File Manager, Image Manager Extended, and Media Manager.

I have tried everything. I set a path to "images/users/$id".

I made it very simple and it's not working. (running the newest version of JCE Pro)
more than a month ago
·
#108164

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#108168
Do you have the information?
more than a month ago
·
#108170
I sent you the information already. Did you receive it?
more than a month ago
·
#108174
Having a look at the editor profiles on your site, the ordering of the profiles is crucial. Profiles should be ordered (from top to bottom) so that the most restricted profile, ie: the one assigned for fewest number of users, extensions etc. should be first, then the next least restrictive and so on.

I have re-ordered the profiles on your site so that the "Writer" profile is first, then the "Admin and WebAdmin" and then the "Default", which is the least restrictive (available to the most number of users).

For reference please see - https://www.joomlacontenteditor.net/support/documentation/profiles/profiles-ordering

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#108179
Thank you!!

So, I learn something new, and I will always do that from now on.

However, I have another problem now. It seems there are two "Image" buttons showing. One on the JCE Panel, which follows the permissions perfectly. And another one at the bottom, which DOES NOT follow the JCE Permissions.

It seems only 60% of the buttons are following the JCE Pro Permissions. (See the attached screenshot.)

I read your documentation and there is nothing describing this situation.

Do you know what is causing this? And how I can fix it?


JCE Pro Folder Permission Problems 06-28-2021.jpg
more than a month ago
·
#108180
Buttons below the editor are not JCE buttons, but either from other installed extensions, or core Joomla buttons, like the Image button. The Joomla Image button will therefore open the Joomla Media Manager. If you are not using this button, you can disable it in Extensions -> Plugins.

As for Fields, image fields should usually be converted to a JCE compatible field, but this does not appear to be possible in FlexiContent for some reason, which I will investigate.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#108181
The two fields it DOES NOT work for are Joomla "Intro Image" and "Full Article Image".

Thank you for the reply.

Okay, please let me know when you find a solution for this. Thank you so much!!
more than a month ago
·
#108182
The two fields it DOES NOT work for are Joomla "Intro Image" and "Full Article Image".


These would normally work outside of FlexiContent, which you are using on your site.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#108183
I understand. You are saying that it is 100% caused by FLEXIContent.

Is it fixable?

For some reason, JCE Pro works for my Custom FLEXIContent fields. But, it doesn't work for the Joomla Image fields. That's really bizarre.

If you do find a way to fix it, please let me know.

Thank you so much!
more than a month ago
·
#108203
For some reason, JCE Pro works for my Custom FLEXIContent fields. But, it doesn't work for the Joomla Image fields. That's really bizarre.


Do these fields work in the Joomla admin?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#108204
For some reason, JCE Pro works for my Custom FLEXIContent fields. But, it doesn't work for the Joomla Image fields. That's really bizarre.


Do these fields work in the Joomla admin?


It is the same in the back-end as it is on the front-end. Even if you set the JCE Permissions to a specific directory, the Joomla "Intro Image" and "Full Article Image" will ignore the JCE Permissions when you edit the FLEXIContent article.
more than a month ago
·
#108205

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#108207
I uploaded Beta 2, and it is the same.

If you set the JCE Permissions to a specific directory, the Joomla "Intro Image" and "Full Article Image" will ignore the JCE Permissions when you edit the FLEXIContent article.

Nothing changed.
more than a month ago
·
#108877
It has been a few months, and I wanted to follow-up.

Have you fixed this problem with FLEXIContent yet?
more than a month ago
·
#108879
I did fix some issues with Flexi-Content but was not able to reproduce the issue you described.

Please try the latest beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#108880
If you set the JCE Permissions to a specific directory, the Joomla "Intro Image" and "Full Article Image" will ignore the JCE Permissions when you edit the FLEXIContent article.


The File Browser for those fields will use the editor profile - and therefore the File Directory Path - that fits the current user and environment. It will also only show images in that folder, as these are image fields.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#108881
Okay, I will upload the Beta version and test it this weekend.

Thank you for the reply!!
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!