You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Wednesday, 06 October 2021
  7 Replies
  558 Visits
Hello,
How do I add a background colour to a JCE Column, please?
2 weeks ago
·
#109002
You will need to do this with a custom css style in your template stylesheet, which can then be applied to the column using the Styles list.

For example, add the following to your template stylesheet:


.column_bg {
background-color: #eee;
}


then in the editor, click in one of the columns, and in the Path at the bottom of the editor, click on column to select that column. Select the column_bg style from the Styles list to apply it to the column.

If you want to apply the background to the whole Columns layout, select columns in the Path and apply the Style as before.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#109009
Thank you, code below, is this correct, please?

<div class="wf-columns wf-columns-stack-medium wf-columns-layout-auto" data-wf-columns="1">
<div class="wf-column"><span class="column_bg">Re-Tac 150 White polymeric printable PVC film with ReTac® ultra removable adhesive technology is designed for graphics that need to be easily installed, removed and re-positioned. Find out more</span></div>
<div class="wf-column">
<p><img src="images/homepage-slider-images/Drytac-ReTac-150-250x250.png" alt="Drytac ReTac 150 250x250" width="250" height="250" /></p>
</div>
2 weeks ago
·
#109012
No, because the column_bg class should be applied to the <div class="wf-column">, not to a span.

Did you select the column using the Path at the bottom of the editor?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#109015
I have added to the Custom.css, but column is not appearing in the Styles list.

Is this a Cache problem?

.column_bg {
background-color: #eee;
}
2 weeks ago
·
#109028
Still not seeing the Style in the list, I added it manually -

<div class="wf-columns wf-columns-stack-medium wf-columns-layout-auto" data-wf-columns="1">
<div class="column_bg wf-column">
<p>text here</p>
</div>
<div class="wf-column">
<p> </p>
</div>
</div>

M T's
2 weeks ago
·
#109032
Have you configured JCE to use your custom.css?

https://www.joomlacontenteditor.net/support/tutorials/editor/create-a-custom-editor-stylesheet

Section "Configure JCE to use the new stylesheet"
2 weeks ago
·
#109039
@PhilMay - which template are you using?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!