You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)
  Wednesday, 30 March 2022
  16 Replies
  894 Visits
After updating JCE to 2.9.21, the Javascript code in a custom Joomla module gets stripped when switching from the Editor tab to the Code tab. I have been using JCE on this server for a long time and have not changed the Default configuration. I am using Chrome and my Joomla version is 3.10.6. I have attached screenshots to demonstrate the behavior.
more than a month ago
·
#110714

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#110715
Yes, that fixed the issue.
Ryan marked this post as Resolved — 3 months ago
more than a month ago
·
#110716
Same goes for CSS, installing the beta didn't fix it unfortunately.
more than a month ago
·
#110720
Same goes for CSS, installing the beta didn't fix it unfortunately.


I'm not seeing an issue with css with the beta. Have you enabled the Allow CSS option in Editor Profiles -> Editor Parameters -> Advanced?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#110723
Same here. After a successful upgrade to 2.9.21 everything within {source}{/source} and the whole of <style></style> (including the tags) do not appear on screen, and if saved they are vanished forever.
For the time being I am back to 2.9.20.
more than a month ago
·
#110728
Same here. After a successful upgrade to 2.9.21 everything within {source}{/source} and the whole of <style></style> (including the tags) do not appear on screen, and if saved they are vanished forever.
For the time being I am back to 2.9.20.


This is now fixed in JCE Pro 2.9.22 Beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#110746
Excellent!
Now with the 2.9.22 Beta the "vanishing" effect got vanished.

Thank you Ryan.
more than a month ago
·
#110749

Now with the 2.9.22 Beta the "vanishing" effect got vanished.


JCE Pro 2.9.22 is now available - https://www.joomlacontenteditor.net/downloads/editor/pro/latest

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111087
I am on verson 2.9.22 and my code is being stripped :(
more than a month ago
·
#111088
I am on verson 2.9.22 and my code is being stripped :(


Have you enabled javascript in Editor Profiles? - https://www.joomlacontenteditor.net/support/faq/editor/scripts-removed-on-saving

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111091
Yes, all settings are as they have always been

screenshot

This is a page with embedded youtube videos https://www.walc.org.uk/presentation-videos
more than a month ago
·
#111093
Whata code is being removed?

Is it only removed when you switch to the Code tab?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111094
no, it is being removed throughout.
I am using Joomshaper helix template, I am going to look into that being the problem I think
more than a month ago
·
#111095
What code is being removed?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111096
All code I put into articles / modules

iframes (for embedding YouTube videos)

Javascript for embedding MailChimp feed

php (using sorcerer )
more than a month ago
·
#111097
Its OK Ryan, I have found the problem, it was due to cookies not be correctly accepted - sorry for taking your time
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!