You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)
  Saturday, 06 August 2022
  6 Replies
  293 Visits
first i have to apologize, my english is not good, that's how google translated it. Maybe that's why I didn't find the answer

With the current JCE I enter the following code in the editor

<p class="responsive-video">
<iframe src="//http://www.youtube.com/embed/cXiCJUNwIz8" width="640" height="360" frameborder="0" allowfullscreen="allowfullscreen"></iframe>

When I switch from code to editor, it changes the code even when it's saved. red_different

<p class="responsive-video">
<iframe src="//http://www.youtube.com/embed/cXiCJUNwIz8" width="640" height="360" style="width: 640px; height: 360px;" frameborder="0" allowfullscreen="allowfullscreen" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"></iframe>
</p>

insite template i use this code

.responsive-video {
position:relative;
padding-bottom:56.25%;
padding-top:15px;
height:0;
overflow:hidden;
}
.responsive-video iframe {
position:absolute;
top:0;
left:0;
width:100%;
height:100%;
}

in the TinyMCE editor it works even if I switch the code sector on or off.
I've been using this code for a long time, no problems so far.

Greetings
more than a month ago
·
#111644
Accepted Answer
Thank you again.

I didn't mean anything bad about the HTTP, no criticism, sorry. That's just how automation works. I could have come up with the idea myself, but at least I noticed it.
;)
Everything is ok, if you have time and unlock it, I'll be happy to enter it on my website, many will probably be happy.

Greetings Beat Feser
more than a month ago
·
#111636
Please try JCE Pro 2.9.29 RC - https://www.joomlacontenteditor.net/downloads/editor/pro/development

This will now correctly remove the style dimensions values if the code contains attribute dimension values. You code will now be:


<p class="responsive-video">
<iframe src="/http://www.youtube.com/embed/cXiCJUNwIz8" width="640" height="360" frameborder="0" allowfullscreen="allowfullscreen" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"></iframe>
</p>


which is valid Youtube embed code.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111640
Dear Ryan

Thank you so much for the help. This works again with 2.0.29 RC.
It converts old code from to exactly new code from you and I don't even have to replace the old ones, they are automatically adjusted and continue to work.

Great, but with your code the message comes up:
Not Found The requested URL /http://www.youtube.com/embed/cXiCJUNwIz8 was not found on this server

But without /http: it works.

I mentioned the problem interestingly on my website,
https://www.cms-joomla.ch/index.php/inhalte-erstellen/video-responsive-schalten
because others had some problems too, but on your side (I've been using the pro for a long time) the 2.9.29 isn't official yet, still 2.9.28. Should I refrain from giving a hint until that is the case?

Greetings from a hobby jooma fan with several pages from Switzerland.

Beat (is a man first name in german not english meanig beat :) ) Feser http://www.feser.ch
more than a month ago
·
#111642
Great, but with your code the message comes up:
Not Found The requested URL /http://www.youtube.com/embed/cXiCJUNwIz8 was not found on this server

But without /http: it works.


The forum extension added the / before the http: so remove this if you are copying the code I pasted in.

I mentioned the problem interestingly on my website,
https://www.cms-joomla.ch/index.php/inhalte-erstellen/video-responsive-schalten
because others had some problems too, but on your side (I've been using the pro for a long time) the 2.9.29 isn't official yet, still 2.9.28. Should I refrain from giving a hint until that is the case?


I might elease 2.9.29 tomorrow (Tuesday), or later in the week.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#111644
Accepted Answer
Thank you again.

I didn't mean anything bad about the HTTP, no criticism, sorry. That's just how automation works. I could have come up with the idea myself, but at least I noticed it.
;)
Everything is ok, if you have time and unlock it, I'll be happy to enter it on my website, many will probably be happy.

Greetings Beat Feser
feser selected the reply #111644 as the answer for this post — 1 month ago
more than a month ago
·
#111645
Thanks again.
I didn't mean the HTTP badly, no criticism, sorry. This is how automation works. I could have come up with the idea myself, but at least I noticed it.
;)
Everything ok, if you have time and activate it, I'll be happy to enter it on my website, many will certainly be happy.

Kind regards, Beat Feser
more than a month ago
·
#111661
Dear Ryan
I was test it on my site and I am happy, it's work well, it chage all old code automaticly.
great work thanks again.
B. Feser
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!