You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Thursday, 29 September 2022
  6 Replies
  349 Visits
Hi,

I have a custom field to upload a PDF from the front end.

I have pdf as a permitted extension on the image manager (plugin parameters) for my custom profile (image attached).

If I enable Joomla's default file browser, I'm able to attach a PDF but I need to use JCE so that I can block users to navigate away from their folder.

Please let me know what other information you need in order to help me.

I have the latest JCE Editor Pro version installed as well as the latest Joomla 4 version.
2 weeks ago
·
#112320
Accepted Answer
Hi Ryan,

thank you for your reply. I've added the epub extension to the default profile, and now it works perfect.

thanks
Cyana
2 months ago
·
#111934
I have a custom field to upload a PDF from the front end.


Have you created the custom field as a Media Field or a JCE File Browser field?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

3 weeks ago
·
#112284
Hi, I created it as a media field I believe.

So its within templates/poc_travela/html/layouts/com_fields/field/pdf.php

I'm guessing I need to add it as a JCE File Browser field?

If so, what would be the location of that file?

Thanks!
3 weeks ago
·
#112285
A pdf file is not an image so it is not handled by the Image Manager parameters. The Media Field (and JCE Media Field) use the JCE File Browser for browsing, uploading and selecting images. PDF files are enabled by default for the File Browser.

I'm guessing I need to add it as a JCE File Browser field?


Yes, this would allow you to set a Media Type when creating the field, eg: files or pdf

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#112309
I'm having a similar problem when I want to create a link to an epub file. I added it as allowed file type in the media settings, and it shows up in the default media browser, however not in the JCE browser. Apparently, the file browser ignores the settings (?)

thanks
Cyana
2 weeks ago
·
#112310
cyana - You need to add the extension to the Permitted File Extensions list in Editor Profiles -> Plugin Parameters -> File Browser.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

2 weeks ago
·
#112320
Accepted Answer
Hi Ryan,

thank you for your reply. I've added the epub extension to the default profile, and now it works perfect.

thanks
Cyana
cyana selected the reply #112320 as the answer for this post — 2 weeks ago
  • Page :
  • 1
There are no replies made for this post yet.