You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

  Tuesday, 24 January 2023
  1 Replies
  142 Visits
Hello, I'm using JCE with Markdown enabled and I've run into a few issues I am hoping you can help with.

I have my Editor Profile set to the Markdown option only and have it available for both Admin and Frontend. I have 'add support for Markdown' selected, and in Global Configuration I have it set to none : paragraph (though I have also tried none : Linebreak)

I've found that when creating a new article (frontend or admin) Markdown language does not work right away. I need to either hit return to start a new line and then can do Markdown like ## Headline, ` code `, etc.

Is there something I am missing in the settings to allow for Markdown to be initiated immediately?

I've also found that when I create a Blockquote section with > the element isn't escaped, and all new lines are being wrapped in the Blockquote tag.

If you are able to provide some guidance on how I may be able to fix these issues it would be greatly appreciated.

Thanks!
Robb
one week ago
·
#112905
I've found that when creating a new article (frontend or admin) Markdown language does not work right away. I need to either hit return to start a new line and then can do Markdown like ## Headline, ` code `, etc.

Is there something I am missing in the settings to allow for Markdown to be initiated immediately?


This is how the Markdown features in the editor work, on Enter for block level syntax, eg: ### Heading1 and when pressing the space bar for inline code, eg: **bold**

Markdown conversion does not occur as you type.

I've also found that when I create a Blockquote section with > the element isn't escaped, and all new lines are being wrapped in the Blockquote tag.


Yes, the blockquote becomes the parent wrapper tag. To exit any block element, using CTRL + ALT + Enter.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!