You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Offline

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)

Please post your question in the Forum and we will get back to you as soon as we can.

  Thursday, 05 October 2023
  10 Replies
  863 Visits
Hi
I'm embedding a YouTube video on a site in German.
I know how to add a YouTube link using the editor mediabox.
What I don't know is how, in the editor, I can add the command to force the choice of language and subtitles.

I've found a solution, which is to add the following command immediately after the link "&hl=de&cc_lang_pref=de" so, as an example the full link would be
"https://www.youtube.com/embed/pNerks2SGQ4?&hl=de&cc_lang_pref=de";
The editor, however, removes the added part and adds "rel=0" instead.

Can you explain how I can keep the added part, using the options in the mediabox? I'm currently just changing it by hand in the code view section.

Best regards
David
more than a month ago
·
#114840
Are you creating the Popup link using the Media Manager dialog?

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114845
No. I'm just using the first tab in the media manager within the editor.

I can get it work when I just use a text link. Here are the two versions:


<h3 style="text-align: center;"><a href="https://www.youtube.com/embed/pNerks2SGQ4?&hl=de&cc_lang_pref=de" class="jcepopup" data-mediabox="1" data-mediabox-width="560" data-mediabox-height="315">Das Friedens-Bildungs-Programm - Ein Überblick</a></h3>
<p>
<iframe src="/https://www.youtube.com/embed/pNerks2SGQ4?rel=0" width="560" height="315" style="display: block; margin-left: auto; margin-right: auto; vertical-align: center;" allowfullscreen="allowfullscreen" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"></iframe>
</p>
more than a month ago
·
#114862
Please try JCE Pro 2.9.51 Beta - https://www.joomlacontenteditor.net/downloads/mediabox/development

Clear your browser cache after install.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114864
Hi
OK, I tried that, and it killed the whole frontend of the site. I had to reinstall the previous version and the site was as before.

It's not clear to me if I should just append the command to the link, as I did in the text link. I tried to do that, but it wouldn't save it all. Just cleared it back to the standard YouTube short code link.

Regards
David
more than a month ago
·
#114866
My apologies, I posted a link to the wrong extension.

Please try JCE Pro 2.9.51 Beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development

This fixes the removal of the additional parameters, placing them in Parameters fields in the Media Options tab of the Media Manager. They should now be retained when creating the popup.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114873
Ok - I did that.
What happens now, is that when I add the parameter as a link like this : "https://www.youtube.com/embed/pNerks2SGQ4?&hl=de&cc_lang_pref=de";
and play the video, it works.
When I check to see if the parameter has been added in the media manager, it has not been retained, and it plays without that parameter again.

So it is the retention which seems to be the problem.

As an aside, I appreciate you adding this - it makes it so much more user-friendly when they don't have to find out where the settings are on YouTube. I'm sure this will be used a lot in future.

Regards
David
more than a month ago
·
#114874
Please try JCE Pro 2.9.51 Beta 4 - https://www.joomlacontenteditor.net/downloads/editor/pro/development

This fixes a bug processing the Youtube URL when editing an existing link or iframe.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114876
Hi Ryan
I'm in hospital and 5 minutes away from am operation. I'll try it tomorrow.
Regards and thanks
David
more than a month ago
·
#114877
Hi Ryan
I'm in hospital and 5 minutes away from am operation. I'll try it tomorrow.
Regards and thanks
David


Good luck, hope it all goes well!

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#114883
That did the trick! Great!
Thanks, Ryan.

Regards
David

BTW - the op has gone well.
Ryan marked this post as Resolved — 4 months ago
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!