You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours:
Monday To Friday
From 09:00 To 17:00 Europe/London (BST)
  Wednesday, 29 November 2023
  2 Replies
  498 Visits
Hello,
I've just installed the table of content plugin on my site and I'm encountering a problem.
I use page breaks to separate my articles, and even if the table of content is generated according to the Hx tags, the links only work if you're on the corresponding article page.

For example, my table of content is like :
- Subtitle 1
- part 1
- part 2
- Subtitle 2
-part 1
-part 2

Well, the "Subtitle 1 - Part 2" link will work if I'm on the Subtitle 1 page, but if I click on "Subtitle 2 - Part 2" and I'm on the Subtitle 1 page nothing happens.

I hope you'll be able to understand my problem, as my English isn't great... And that you'll be able to help me
more than a month ago
·
#115448
The Table of Contents plugin currently only operates within the context of whole article displayed full, as the links only include the corresponding anchor name, and not the article link as well, which is what would be required for the links to work between articles.

I'm not sure this would be acheivable with the Table of Contents plugin, but I will look into it.

Just because you're not paranoid doesn't mean everybody isn't out to get you.

more than a month ago
·
#115456
Hello,
Thanks for the reply

I hope a future update will allow this possibility, it would be really appreciated.
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!