You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours
Monday to Friday
09:00 - 17:00 Europe/London (BST)

#113853 error message after uploading image in ice file browser (media) custom field

Posted in ‘Editor’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Latest post by onderzoekspraktijk on Thursday, 01 June 2023 13:28 BST

onderzoekspraktijk
Hi,

I am using the fields media plugin as a custom field with an article category. This worked okay but recently image uploads results in an error message;
"The server returned an invalid JSON response"

I looked in the forum and saw here were issues with this in earlier version of JCE. Big not for the latest one I am using:

JCE 2.9.37

The site itself is Joomla 4.3.1 with the latest version of a Yootheme template.

The error message itself may be correct, but the image itself will be uploaded after all.

I am not sure where to lok for more information on this issue.

Can you advise on this?

Cheers,
Paul

Ryan
Please send me a login - https://www.joomlacontenteditor.net/contact/site-login

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.

Ryan
Your server or a plugin installed on your site is generating this message when an upload is attempted:

"Web Server crawler feature not enabled, please check web server settings"

This is probably causing the error you have posted about, as it is corrupting the expected JSON response fro mthe server.

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.

onderzoekspraktijk
Hi Ryan,

I asked the helpdesk at the webserver and they confirmed your analysis: it was a setting in the Litespeed component serverside that was not activated (the web crawler), they could activate for my account and that solved this issue.

Thanks for your time and expertise!

Cheers,
Paul