You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours
Monday to Friday
09:00 - 17:00 Europe/London (BST)

#115920 Change in JCE Media fields?

Posted in ‘Editor’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Latest post by rian on Tuesday, 23 January 2024 10:40 GMT

rian
I am using YOOtheme dynamic content to show a download button if there was a file uploaded to a jce media field in the article. Of course this button should not be shown if there is no file in the field. This used to work, but I just discovered that recently this buttons shows up, although the field is emtpy.
It created a button with some JSON in it.

The strange thing is that on older article it still works as it should, only of I create a new article or copy an older button than it would show up. What is going on here?

Attachments

Ryan
Of course this button should not be shown if there is no file in the field. This used to work, but I just discovered that recently this buttons shows up, although the field is emtpy.
It created a button with some JSON in it.


This change was introduced a few versions ago to add a Description field to the Media Field. Because Yootheme dynamic content accesses the unprocessed database value expecting it to be a single URL value, which has now changed to uses a JSON object containing multiple values, the dynamic content field does not work as expected.

In order to continue to use the JCE Media Field for Yootheme Dynamic Content, you will need to enable "Legacy Media Support" for the Media Field.

See the "Legacy Media Support" section of this article - https://www.joomlacontenteditor.net/news/jce-pro-2-9-58-released

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.

rian
thanks, I tried to enable the legacy media support, and I realized that I have to save the article again, to make it work. thank you!