You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours
Monday to Friday
09:00 - 17:00 Europe/London (BST)

#116267 Media field fall backs to Joomla file system when AWS S3 is active

Posted in ‘Editor’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Latest post by Ryan on Tuesday, 27 February 2024 16:21 GMT

kcoweb
Hi there, I have a faint memory that this worked in the past but for the last year or more the joomla media fields (eg menu item link image or article intro & full image) kept showing joomla filesystem instead of S3 -- which in the meantime worked all right within the editor. Works really well in combination with cloudfront. Took me a day of messing around with debugger to figure it out, it's a trap of passing objects by reference. There's a bit of code in components/com_jce/editor/libraries/classes/extensions.php that alters cached plugins list entry, In particular it rewrites the name property so filesystem-s3 becomes s3 and the plugin is no longer recognised. Dereferencing $p fixes the problem. Lines 81-83: Before

        if (!empty($installed)) {
            foreach ($installed as $p) {
After

        if (!empty($installed)) {
            foreach ($installed as $ppp) {
                $p = clone $ppp;

kcoweb
I mean, please include in the release and thanks

Ryan
This is fixed in JCE Pro 2.9.63 Beta - https://www.joomlacontenteditor.net/downloads/editor/pro/development

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.