You need to be logged in to post in the forum - Log In

An active JCE Pro Subscription is required to post in the forum - Buy a Subscription

Support is currently Online

Official support hours
Monday to Friday
09:00 - 17:00 Europe/London (BST)

#116343 Error Trying to Access Registration

Posted in ‘Editor’
This is a public ticket

Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.

Latest post by TAGLLC on Sunday, 03 March 2024 23:43 GMT

Hi Ryan.

I'm sure you are going to tell me that it's something I did, because JCE "rocks"! So here goes.

I updated a site for one of my clients today and everything seemed to go great. I updated to J5, updated to Php 8.2 (from 8.1), and changed J5 "Database Type" to MySQL (PDO) to work with mysqlnd.

As I mentioned, everything works with only 1 exception - the registration page.
I can't get to it.
What's that have to do with JCE? Read on...I wondered why too.

I've chased my tail for over an hour trying to find where I may have made a mistake. But I can't find a thing.
When I attempt to go to the registration page, I get a 404 error: The page cannot be found
That error is followed by:
If difficulties persist, please contact the website administrator and report the error below.

0 Too few arguments to function Joomla\Plugin\Editors\Jce\Extension\Jce::onDisplay(), 3 passed in /server/account/ on line 289 and at least 6 expected

I have updated 2 other sites this week to J5 and no problems. 2.9.62 is the JCE version.

I just this minute realized the difference between the 3 sites.
I updated 2 sites without issue before this site that's throwing the errors.
The other 2 sites are using JCE Pro and this site is using JCE free. That should help you narrow things down.

I'm ready for you to say I forgot something...but I'm hoping it's just something in JCE free that's not providing enough arguments.

If it's something you'll get to later, I'll just install Pro in this site with the issue (which it should have Pro anyway) and then go on my merry way.

Thank you.

First thing to do on the problem site is to uninstall JCE -

and re-install the latest version -

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.

I uninstalled per the instructions, and although in your instructions "Pro" was stated to install, I "had" the free version installed in this site that was throwing the errors. So I "reinstalled" the free version using the latest download - 2.9.62

That resulted in the same error when attempting to hit the "Register" page.

So I uninstalled that via your instructions again. That time I wanted to see if I got the errors with JCE completely uninstalled. I do. Even after clearing cache everywhere.

At that point, I tried to install Pro - 2.9.62. After I installed Pro I checked the front end again and got the same error when attempting to access the register page.

I tried clearing cache (browser too), even though I have non enabled there are areas that Joomla still has cache and I cleared them all.
I even disabled the menu item for Register in order to see if the Login Form link to create an account would do anything different. But no. The errors are thrown every time I attempt to hit the registration page no matter what method I use to get there.

I've never had any issue similar to this with JCE, so I'm out of my depth. I'm guessing you'd like to get in and see what you can find. Correct?

I do have Virtuemart installed and in use.
So you know, this is a very delicate dance to mess with this site because it uses Virtuemart extensively for all the products in the site. The site isn't exposed to the public (yet) because it's in production. But it has a years worth of work getting it to the point where it is currently, so I'm nervous about messing with too much.
I did take a backup of the site and database before doing any updates.

Of course, would you know, I just now found an alert in Virtuemart that states to use MySQLi in order to assure things work correctly.

That brings up an entirely different set of issues.
I updated to Joomla 5 prior to finding the register errors.
I updated to Php 8.2 and, as you may know, mysqli is no longer supported in 8.2, so mysqlnd is mandated. In order to use mysqlnd I had to switch the Joomla Database Type to MySQL (PDO). So now there is no option for mysqli in Database Type.

Oddly, I got that Virtuemart notification, navigated to other parts of admin, then returned to Virtuemart and there is no longer the notification. So that made me feel a little better.

So I'm going to go think. Hopefully you have a plan.

Please test with the Joomla Tinymce, CodeMirror and "No Editor". Do you get the error with any of these?

Ryan Demmer

Lead Developer / CEO / CTO

Just because you're not paranoid doesn't mean everybody isn't out to get you.

Yes, I tried that. I uninstalled everything related to JCE, even checked the database and could find nothing. I had the same idea as you in that I tested after removing JCE, then switched to the various editors and nothing made any difference. I got the same errors no matter which editor, or none.

Eventually, the system stopped showing anything related to JCE in the error. That was even further verification it was not JCE.

Good news for you is, I've "confirmed" it's the redirect in Virtuemart. So I posted a bug about it to them, although this is critical for sites that are selling products, which I am in 2 of the 3 sites I've updated.

This means, don't update Joomla if you are using 4.x.x and Virtuemart. Your users cannot register through Virtuemart if the site is updated.
Now I have 2 sites that users cannot purchase if they have not already registered before this issue.

You can disable the redirect, but that only allows the Joomla default registration to function 100%.
If you put something in the Virtuemart shopping cart and hit "Check Out Now", you are met with the errors and will never be able to complete the purchase. THAT is going to give me some serious stress the next several days.

I checked thoroughly to assure that nothing is wrong with JCE. The site has the exact same error message when JCE is not installed, and with no matter what editor is selected. It's not the editor at all. It's something about Virtuemart and how whatever is coded improperly for Joomla 5, displays an error message that has nothing to do with the exact error.

Ryan still sits at the head of the class. Thank you!